P800 Cartridge error LLK channel after decoder board installation

Sorry if I posted this question in the wrong group - still learning how this is all set up.

I’ve purchased a P800 (North America), verified the printer worked and the nozzles are printing correctly before proceeding to install the decoder board and inks (PZPRO). After installation of the decoder board, I am receiving an error the the LLK cartridge is not recognized. I’ve attempted reseating the cartridge, verified the ribbon cables are seated well, checked the contacts on the cartridge in case there was some debris (none) and I’ve even reset the decoding board several times. On the first reset, all of the cartridges were not recognized. A restart got rid of that problem but the LLK cartridge is still not recognized. What’s even more puzzling is that I saw this error when I first installed, then it went away once. I had a happy day of printing and tutorials. Now, I can’t get the printer to recognize the cartridge again.

I’m also unsure why the MK channel appears darker gray. Since I don’t know the printer well, could anyone comment if this is normal? .IMG_0915

Thank you for any insight or help,

Raymond Hulse

PK is the selected ink, that is why MK is greyed out,

We’re going to get you a replacement decoder board. You may need to hit the resetter a few times to get it working if you’ve already cycled through some serials . . . I will need that decoder board back for investigation.

InkjetMall 17 Powder Spring Rd, Topsham VT 05067

best regards,


Thank you. I had a look at the board again yesterday. I tried to reseat the ribbon cables and a new channel has also been lost (YK). I am now suspecting that it is the cable that is the problem. The pins/slots on the 78 cable don’t have an even contact pattern versus the other two cables. Would a new ribbon cable be easier to test?


All right, we’ll send new ribbon cable. We have some extra here at IJM in Vermont.

Best regards,

Thank you again Walker. I’ve had a chance to cycle through with the suspected ribbon cable. The status of the two cartridges has not changed - they are not detected. Did reset, reseat as well. No change. So my initial thought about the cable was incorrect. Could I have a board sent to swap out? I’ll send the other back when I receive it.

Thank you,
Raymond Hulse

Hi Ray,

I’ll send another board your way. Please return the defective and additional ribbon cables to:

Attn: Walker
17 Powder Spring Rd.
E. Topsham, VT 05076

I’ll follow with a USPS return label in another email. Also, due to the holiday, the board will ship no sooner than next Monday.

We appreciate your patience while we figure this out.

Best regards,


I’ve tried the new board. Please see below for review. I noticed that another user was experiencing the same problem (cyan) but was able to get the system to work with the new board. Here is what I did:

Briefly the steps taken with new board

  1. Swapped new board in. Same problem. LLK channel not detected with two new channels. PK and YK.

  2. Power cycled, Reset - then YK only failed.

  3. Reset - still same. Power cycled.

Now, I swapped out the old cables for the cables that came with the 2nd board

  1. No power on printer. Could not power on at all.

  2. Checked orientation of cables. Checked harness for power supply. Correct.

  3. Check outlet and cord, both working.

Removed board, returned vendor cables. Inject cartridges still in place.

  1. Powered on. LLK and YM cartridge not detected, All others detected.

  2. Replaced with manufacturer, power cycled. All cartridges detected.

This suggests to me that the cartridges were at fault. Either not seating well or making contact. Is this possible?