New Ink Cartridges Not Recognized


#1

Hello Everyone – First time poster, and hope I’m not posting a question that’s been asked many times before…

I just got my Piezography Selenium K7 Inks (for printing both matte and glossy), went through the entire process of filling the new tanks, removing the chips from the Epson tanks, installing them the proper way, snapped the large chip back over top of each one, inserted each cartridge firmly back into my Epson 3880, made sure that all the cartridges were in their correct location (Magenta with Magenta, Cyan with Cyan etc), turned the printer on and…none of the cartridges is recognized.

The message on the LCD screen is ‘NO INK CARTRIDGE’ and all 9 positions are flashing. I took each one out, carefully verified the position of each Epson chip, re-seated each large chip (yes all three plastic tabs are present on each one, all three pins underneath are present and accounted for), and even cleaned the contacts on the large chips with a bit of contact cleaner and turned the printer off and on a couple of times, but still no go. And I repeated this process a couple of times.

So now what? Any suggestions?


#2

Hi Vince~

Occasionally, if one cartridge doesn’t have a good fit/connection, it will make the printer display “NO INK CARTRIDGE” for all nine carts as you are experiencing, though the same error will be displayed if there’s not a good connection between the large reset chip and Epson chip underneath.

Wells just forwarded me an email from you, which I’m including here for others who read this thread:
“Further Update — I just pushed those pins on that yellow cartridge in and out and played with it a bit, and now it seems okay (though potentially precariously so). So it seems that the large chip on the yellow cartridge is the culprit. [B]Vince.[/B]”

Please keep me posted and let me know if problems/errors return, if you have questions, or there’s anything else I can help you with.

Best regards~ Dana :slight_smile:


#3

Hi Dana - thanks for the reply. How I found out it was the ‘yellow’ cartridge was that I was pushing in on each one of the cartridges to make sure that they were properly seated, and when I got to the yellow one, the message on the LCD changed to ‘Close Lid’. However, when I let go of the yellow cartridge, it reverted to the ‘No Ink Cartridge’ message. I pulled out the cartridge and examined the large chip. I seem to recall having read that all three of the ‘pins’ on the underside of the large chip should be the same length – well, one of them was shorter. So I pushed it in a few times to see if maybe it was binding or something, and that seemed to fix it. Now, I’m sure I could jiggle the cartridge again to make that error message come back on, so I’m going to keep a close eye on it (and not touch it!).

Thanks again.


#4

Thanks for the additional information. Please do keep me posted and let me know if there’s anything else I can help you with.

Warmly~ Dana :slight_smile:


#5

Sorry, it’s acting up again. Grrr…


#6

Okay it’s now recognizing it again. But I’m sorry, I can’t quite get the hang of this yet – I downloaded all the things that I think I needed to download (printing on an Epson 3880, using Exhibition Fiber Paper), downloaded my 30-day trial of Print Tool, installed the curves in the QuadTone RIP Curves folder, made a print, and it looks very light. I then tried to do the gloss overprint (yes, made a 1"x1" square), but the printer does absolutely nothing. It just sits there. What am I not doing right?

Either I’m an idiot (which is entirely possible!) or your setup/operation instructions are not entirely clear…


#7

I do not think that you are an idiot, but I also think our instructions are very clear. I’m jumping in here on this thread that Dana has been helping you with. So be patient with me.

  1. You do understand that we have a Gamma 2.20 workflow according to the NEW Piezography Manual, correct? (I ask to determine if the lightness is in response to what you see on your display, or whether the image may have been converted by the Mac OSX by not following our workflow.)

  2. On the GO - you selected the GO curve when you printed and the printer does nothing. That may indicate that you did not have the Quad-K7 printer selected and have sent the GO curve and image to be printed by the Epson driver version of your printer model. Can you confirm?

I’m in the studio working today so if you follow up I will reply…

Jon


#8

Okay, made a bit of progress, but then went two steps back. Basically started from scratch, re-downloaded everything, made sure that everything was in the right spot (I think!), opened a grayscale 8-bit image, converted it to a ‘gray gamma 2.2’ profile, resaved it. Then I opened it up in print tool, chose ‘no color management’, then hit print, chose Quad 3880 as my printer, chose 3800-3880-MPS-EPexFiber as ‘curve 1’, left everything else alone (per the manual), black ink is ‘Installed’, hit print…and the print came out deep magenta and yellow!

So what am I doing wrong?

BTW this is the photo I’m working on:


Wild Horses by Vince.Lupo, on Flickr


#9

Did two additional ‘power cleans’ to make sure that all the residual Epson inks were purged, ran another test print, and it’s looking better. Not as shocking magenta and yellow as it was. As well, I chose ‘Photo Ink’ instead of ‘Installed’ to see if that made a difference.

So hang tight while I test again…it can only get better!


#10

You have not properly prepared your printer for Piezography. You need to rid the printer of all of the color inks by performing at minimum three POWER CLEANS. Power Cleans are not regular cleans. They are a special type of clean that will move about 40-50% of the color ink in your printer out of it. This is why you need to perform three.

Our instructions:

[ol]
[li]Perform 3 Power Clean Cycles after installing carts to purge color ink and get Piezography ink from carts to the print head. Print a nozzle check to make sure all positions are fully printing, then print a test gradient and examine it for color staining. Yellow, which is the worst for color staining, will show up in the highlights. If color staining is present, do another Power Clean Cycle or a few regular cleaning cycles. Follow this by printing another gradient to make sure color is gone before printing images.[/li][li]Verify that you have a perfect nozzle check pattern before printing images.[/li][/ol]

Page 92 of the Epson 3880 printer manual

[B]Running a Power Cleaning Cycle[/B]
You can run a power cleaning cycle from the control panel if the normal
cleaning process is not sufficient to clear the nozzles. However, the power
cycle uses a large quantity of ink, so it is recommended only as a last resort.
The cartridges need to be at least 50% full to use power cleaning. You may
need to replace a low cartridge to run the cleaning cycle. After cleaning, you
can reinsert the old cartridge.

  1. Print a nozzle check to make sure the print head needs cleaning, as
    described on page 90.
  2. Make sure the printer is ready and the red B ink light is not on or
    flashing.
  3. Press the Menu r button.
  4. Press d until MAINTENANCE is highlighted, then press r.
  5. Press d to select POWER CLEANING, then press r.
  6. Press the Enter button to start the power cleaning.
  7. When cleaning is finished and the P Power light stops flashing, print
    the nozzle check again to confirm that the head is clean.

#11

Okay, having better success. The gloss coat now works, yellow and magenta are gone. Did the additional maintenance.

Now it’s too dark though – about 20% darker than what the above image looks like on screen.


#12

Have you calibrated your display?


#13

Yes, display is calibrated. When I would print with the 3880 loaded with the standard Epson K3 inks, the resulting print would look exactly as on screen.

So I adjusted the brightness of the photo in PhotoShop, re-saved it and re-printed it. Success. Now my maintenance cartridge needs replacing soon – oy!

The only thing that I’m noticing (compared to the same image printed with the Epson inks with the same paper) is that it does not look quite as sharp. It’s ever-so-slight, and I’m the only person who’d probably notice it, but I see it. Something I still haven’t done?


#14

There is an absence of screening dot with K7. So bring the image file up to 100% pixels view and sharpen at that level to your taste. If it looks too sharp at 100% pixels view it is. If it does not look sharp enough at 100% pixels view, then it is not. Only judge that 100% view.

Turn your calibration down to 80-85L or candelas for a more accurate view.


#15

Thanks for the help Jon – I knew this was going to be an involved process to make the conversion to these inks, but it’s something that I’ve wanted to do. All part of the journey!


#16

Once you get the hang of Piezography printing - it really is second nature…
But let us know if you need help in the meantime!


#17

Bad news - The ‘yellow’ cartridge is acting up again. I think I need a replacement chip.


#18

New problem this morning – all my prints are coming out grey and ‘solarized’. No deep blacks. I’ve tried printing the same file 4 times, and another one once. I haven’t changed any of the settings. Plus, I took out each cartridge and gave it a shake (though the last time I used the printer was only three days ago). This is becoming a very expensive experience :frowning:


#19

I will send you a replacement chip.

Did you print a nozzle check to make are all channels are printing?


#20

Thanks Dana – You have my mailing address?

What I did do what a ‘Power Clean’ and it seemed to clear it up.

I hope I start selling some of these prints – need to pay for all of this somehow!