Yellow Blocked up in Epson 11880


#1

Hi all :slight_smile:

Congrats on making it through the holiday! We have been dealing with a blocked up yellow for a couple of weeks and managed to limp through the season but now we need to get it taken care of. This is a new one to us, when we send a print the first quarter inch prints correctly and then it looses most of the yellow channel. There is no visible banding in the final print, it just doesn’t have the warmth it should. We have tried cleaning the print head with Piezo Flush with no luck. Has anyone else come across this?


#2

I haven’t seen this in specific. The easiest thing to look at first would be the damper. If the one handling Yellow has crapped out on you, it could cause this. If the dampers haven’t been replaced, or not for some time, then it’s likely beneficial to replace them all anyway, just on general principles. It’s a pretty easy change, low risk, and not that expensive. Do use the Epson OEM dampers, if you go this route. The cheap Chinese knock-off dampers I’ve tried have all been horrific mistakes.

If it’s not the damper itself, and it’s only the Yellow channel doing this, then it seems next most likely it may be something in the Yellow feed. Either the line or the cartridge seal perhaps has a kink, blockage or air gap, and the feed can’t deliver ink. The cartridge itself could be at fault, if you didn’t try a different one to rule that out already.


#3

Thank you Royce, we really appreciate your help on this one. We haven’t replaced the dampers in this machine and it has been running daily for about 4 years! Through our research it seems like it may come down to the dreaded print head replacement… We have tried other cartridges, and upon visual inspection the lines look great.
We will keep you posted!