Sporadically Epson 4900 does not recognize Cartridge


#1

I just used the MK refillable cartridge from a full set for the first time. The printer was happy for a while, and then mysteriously stopped, saying the wrong cartridge was installed. I put in the old empty cart, closed the door, and waited for it to ask for a new one. I then replaced the empty cart with the new refillable one, and it worked for a while. It has done this several times and taking it out, putting in the old one, and then replacing it seems to work, but is unworkable in the long run.
I did read the thread about replacing batteries, but the ones I have do not require replaceable batteries. This is a brand new never before used cartridge. What should I do?


#2

We can get you a replacement control chip. I suggest a backup set for this printer as default. (I ran several of these over the years in other labs before working at IJM and needed a backup set generally. It’s a function of the printer and it’s attempt at third party chip lockout.)

I will PM you,
-Walker


#3

That fixed it. Thanks so much, Walker, for your prompt support.