Solved: Problem w/p2 carts: carriage lid won't latch shut; now carriage is stuck

inks
piezography

#1

I loaded piezo carts into printer. I think I did everything right. I shut lid for carts and pressed ink button. Carriage moved very little and then stopped. Paper and Ink lights started flashing. Power light is now off. Then I noticed carriage lid is not latched and I can’t get it to. Finally, carriage is slid just under printer frame on right side of printer, so I can’t open lid to check carts.

That is my tale of woe. Thanks in advance for helping me.


#2

Hi David~

It sounds like you didn’t close the cartridge carriage lid all the way, and it got caught on the printer’s plastic frame, which caused the flashing light error. I recommend turning the printer off, then see if you can either push the lid down so it snaps closed, or move the carriage over to the ink change position to close the cartridge lid, then slide the cartridge carriage over to the far right hand side and turn the printer back on. It should go thru it’s normal startup procedure, then give a solid green power light when it’s “ready”.


#3

Hi David~

It sounds like you didn’t close the cartridge carriage lid all the way, and it got caught on the printer’s plastic frame, which caused the flashing light error. I recommend turning the printer off, then see if you can either push the lid down so it snaps closed, or move the carriage over to the ink change position to close the cartridge lid, then slide the cartridge carriage over to the far right hand side and turn the printer back on. It should go thru it’s normal startup procedure, then give a solid green power light when it’s “ready”.