Solved: 3880 LLK cartridge not recognized

3800
3880

#1

Hi,

I’ve just replaced my old Cone system with the new cartridges, Pro inks, and your new Epson chips. The printer isn’t recognizing the LLK cartridge (“Please Install the Correct Cartridge”). I have gone through all the suggested steps for correcting this: checking the click tabs on the reset chip, inspecting the contact pins on the reset chip, pressing the reset chip firmly into place, cleaning the contacts. I even re-installed my old Epson chip from the old Cone system, removing the tape and cleaning the contacts, to see if that would work. Nothing has made a difference. What would you suggest at this point?

Thanks,
Merrill


#2

Hi Merrill~ We will send you a good working LLK reset chip today. Please let me know if you have questions or there’s anything else I can help you with.
Best regards~ Dana :slight_smile:


#3

You guys (and gals) are the best!

Merrill


#4

We try! Please let me know if there’s anything else I can help you with.
Best regards~ Dana :slight_smile:


#5

Hi Dana,

I haven’t received the reset chip yet. Seems odd, you’d think it would have arrived by now. Maybe the storm held things up(?)

Merrill


#6

Hi Merrill~ I just tracked the chip we sent you on 2/8, and see it’s scheduled to be delivered today.
Please let me know if there’s anything else I can help you with~ Dana :slight_smile:


#7

Hi Dana,

The chip came today. Thanks. Guess I was too impatient! Anyway, I installed it and the printer recognized it. But…(why oh why do these things happen to me?) then the printer didn’t recognize the PK cartridge (blinking icon). I removed and reinserted it, at which point, all the cartridge icons started blinking. Then I turned off the printer, waited, and turned it on again. Same thing. I tried removing and re-installing all the cartridges (with the printer on, in the order I used to do for the old cartridges) but no change. I also notice that the maintenance cartridge, which is new, registers full. (sound of tearing hair)

Merrill


#8

Hi Merrill~

When you first installed the set of refill carts into your 3880, were all carts recognized correctly, except the LLK was flashing with the “Please install the correct cartridge” error? Is your printer in MK or PK mode?
When you replaced the LLK reset chip and reinstalled the cart, the LLK was recognized by the printer, but now PK is flashing?
What is the exact error displayed on the printer’s LCD panel now with the PK icon flashing?

Please make sure the labels on the sides of all carts are secured to the carts and not peeling back, press all chips down to make sure they’re all the way down on the carts, then reinstall the set of carts into their correct slots and close the cartridge bay door to check the cartridge read. If the PK error continues, open the cartridge bay door, remove the PK refill cart and reattach the Epson PK chip onto the PK Epson chip, reinstall the Epson PK cart/chip (along with 8 other refill cart) and close the cartridge bay door to see how the printer responds.

Please let me know if you have any questions or your results so I can help you get back to happily printing.
Best regards~ Dana :slight_smile:


#9

All the carts were recognized, except the LLK. The printer has always been in the PK mode.

After replacing the LLK reset chip, yes, the LLK was recognized but the PK was flashing. I then removed the PK cart, pressed the reset chip and reinserted the cart. At that point, all the cart icons started flashing and the error displayed “No ink cartridge. Install ink cartridge”. I have since removed the PK cart, removed and reattached the reset chip and reinstalled the cart. All cart icons continue to blink and the same message (“No Ink Cartridge. Install Ink Cartridge”) displays. The bay door is closed.

Merrill


#10

Hi Merrill- Thanks for the update. It sounds like one or more of your carts isn’t pushed in all the way for a good connection with the chip and sensor. Please follow the printer reset procedure located in the troubleshooting section of your refill cartridge instructions. After reinstalling all the carts, check to make sure the LCD panel displays “ink cartridge door open, close door” before closing the door. If a different message is displayed such as “no cartridge”, then push each cartridge in while watching the LCD panel to determine which cartridge is causing the error.

Please keep me posted and let me know if you have any questions.
Best regards~ Dana :slight_smile:


#11

Hi Dana,

Well, that seems to have done the trick!
Thanks so much!
Merrill


#12

Excellent- glad to hear!!

Happy printing~ Dana :slight_smile:


#13