SC-P6000 strange Piezoflush PK / OEM (Epson) MK problem

Background: I am converting an OEM SC-P6000 to PiezoPro inkset for DTP, PiezoDN, and matte only Piezography.

I filled an IJM cart with PiezoFlush per instructions. I removed the OEM PK cart and installed the flush cart (with a series 1 PK chip). The printer recognised this “new” PK (Piezoflush) cart (from the display). However, after closing the door, and the printer initialised, it indicated that there was no MK cart (there is an OEM MK cart with about 2/3 ink). If I remove the Piezoflush PK cart and replace it with an OEM PK cart the MK “missing cart” error goes away. I can print perfect nozzle checks (with OEM MK / PK), switch MK to PK without issue. I have checked the MK OEM chip for debris / dirt and none was found. I checked the PK (flush) IJM chip to make sure it was flush in the housing and there was no debris.

I have tried power cycling, and removing and reinserting both the MK and PK carts.

Is it possible, somehow, since MK and PK share some circuitry and one ink line to the head, that the printer sees some sort of a conflict between the OEM MK chip and the IJM Series 1 PK chip?

thank you!

This is a first time I’ve seen this issue. Can you put the OEM back in, switch the K ink to the other one, then put Flush in and tell me if it works? It may be a sequence problem.


1 Like

Good guess Walker!

I had to switch two times: PK->MK and then MK->PK (both times with PK OEM installed and then swapped to flush PK). Now both carts are reading correctly.

Interestingly before the printer started the ink switch it did a cleaning cycle (and I have auto-cleaning turned off). – both times. I then ran a nozzle check (from the printer keypad) and before it would print it, it did another cleaning cycle.

I do have a perfect nozzle check, :-)!

Thank you,


Good to know that worked. I hope if this crops up for anyone else this post can be the reference for the solution.


1 Mar update…

Today I resumed cleaning the ink lines using the flush target image and ran into the following problem:

Upon power up the printer recognized both MK (Epson) and PK (IJM refillable cart with series 1 chip) as displayed. Black ink was set to PK. After loading a sheet of paper to start a print run the printer stopped and displayed the “no cartridge installed” error message; and the display for the MK slot was white with a blinking red x.

I removed and reseated the MK cart several times. I also cleaned the contacts on the MK cart. I examined the mating contact assembly inside the printer cart housing (from an iPhone photo) and they are perfect. I also tried removing the IJM PK cart and re-inserting the PK and MK carts differently (PK first then MK and vice-versa). I did the above procedures 10 or more times each time closing the door. Each time the printer recognised each cart but then after a few seconds or more the “no cartridge inserted” error reappeared.

I also tried switching from PK to MK. The problem persisted,

The last procedure I tried was removing the IJM PK series 1 cart and reinstalled the Epson PK cart. After this there were no more “no cart error” messages and I was able to continue to run the flush image file many times without any issues.

So it seems that there is a conflict (perhaps intermittent as this worked before) between the Epson MK and IJM PK series 1 cart.

Eventually the MK slot will be with an IJM series 1 chip with IJM UHD MK ink and the PK slot will be back an IJM series 1 chip filled with Piezoflush.