Rebuilt 3880 not laying down ink

I just had my 3880, equipped with Piezograhy ink set, rebuilt from an authorized Epson repair center. It needed a new print head and then the mother board died, so a new mother board was installed.
I reinstalled the 3880-P6 print driver.
I get ink when I do a nozzle check, but when I try to print an image the print head moves across the paper, but no ink is laid down on the paper? Consequently a white sheet of paper emerged from the printer.
Any idea as to what the problem is and a solution.
Thank you for your assistance with this. I appreciate all replies.

please share screenshots of your workflow including curve selection, etc.



Here are screen shots:
Screen Shot 1 2021-06-17 at 3.18.21 PM
Screen Shot 2 2021-06-17 at 3.18.40 PM
Screen Shot 3 2021-06-17 at 3.18.00 PM

Thank you.


It looks like it should print just fine.

Print this target in “calibration mode” (aka, not 16-bit but calibration mode) and if that works it’s something with your curve install. (674.6 KB)


Thank you for your reply.
I am away at the moment, but will try your suggestion when I get home on Thursday.
Take care and stay well.

Good afternoon.
An update on my printer issues.
I can print from Word to the 3880 without a problem.
I reinstalled the print drivers, but printing g from Photoshop is still the same issue. The paper is feeding through the printer, the print head moves across the paper, but n o ink is deposited on the paper.
I thought that there might be a conflict between the 3800 and the 3880-HDK6, so I deleted the 3880 printer, but that did nothing.
I have not tried to print the test file you sent as I am confused as to where the calibration mode is in the print dialogue box in Photoshop.
Any suggestions you might have are greatly appreciated.
Thank you!!!
Have a great night.

Good afternoon.

I have reinstalled QTR 2.80 and the Pieziography print drivers.
I have tried to print from older versions of Photoshop, but the results are the same. Paper feeds, print head moves, but no ink is deposited on the paper.

I did some playing around with the print dialogue box settings and low and behold, if I set the resolution to 1440, the printer responds and puts ink on the paper. At 2880, no ink is put on the paper.
The quality is far from what it was or what I want. The blacks are not black.

Any ideas on why it will not print at 2880 resolution?
Have a great day.

Hi Larry,

I’ve got a few thoughts to share about your 3880 issue(s). They may or may not be helpful.

  1. I see you started another thread on this topic. It would be helpful to anyone trying to help you if you kept it all in a single thread.

  2. Since the new parts were recently installed by an authorized service center, have you inquired with them about what testing they did afterwards. My hunch is that is where you should be going with this issue.

  3. From the screenshots you posted it appears that you are printing directly out of Photoshop. OS X 10.5.8 (Leopard) was the last Mac OS version that played well with Photoshop due to a change in color management that eliminated the No Color Management option that is necessary for printing with Piezography and QTR. Roy Harrington (the creator of QTR) developed Print-Tool in response to that issue which began with the introduction of OS X 10.6 (Snow Leopard) in 2008. If anything has changed with regard to this since then it would be news to me. Print-Tool is mentioned frequently throughout the Piezography Manual and other documentation as well as in the IJM and Piezography forums. This may have nothing to do at all with your current situation, but I’ll betcha a beer (based on the screenshots) it has been causing you other issues. If you are using Print-Tool please let us know.

  4. It looks like Walker sent you a 10 channel ink separation file by mistake. You should be using an 8 channel ink separation file for the 3880. I’m not sure what would happen trying to print a 10 channel image with an 8 channel printer, but it might be causing some sort of issue. I think you will find an 8 channel ink separation file (inkseparation8.tif) in QuadToneRIP > CurveDesign > Images.

  5. Which version of MacOS are you using? QTR 2.8.0 is supposed to be compatible with everything from Big Sur back to Mavericks, but it is a recent release (April 2021) and seems to me more likely than Photoshop to be causing problems. That is not to say either is likely. Did you upgrade to 2.8.0 before the printer was serviced? If so, was it working well at that time?

  6. The print dpi setting, 1440 or 2880, should make little difference in print quality (some but not much), though it is very interesting that you are getting some ink flow at 1440 but none at 2880. Black should be very nearly equally black with either. I think this points back to #2 above.

That’s all I can think of right now. Hope it is helpful.


Kevin & Walker,
First, my apologies if I have done something wrong by starting a new thread, but I thought it might elicit some new responses from Forum members.

Thank you for yuor comments. Here are my replies.

  1. I am in contact with the Epson Repair center about the testing they did. I am awaiting their reply.

  2. Prior to the print head replacement, I was printing with Mac OS 11.2 with QTR 2.7.10.

I was running PS 22.3 prior to the repairs. I upgraded to PS 22.4.2, but reinstalled 22.3 to test if the upgrade was the issue, but apparently it is not.

Screen Shot 2021-06-27 at 10.00.34 AM

Here is a shot of an image that was printed prior to the repairs and the same file printed yesterday. The same printer drivers and profiles were used for both. The only difference is the one on the top, from yesterday is was printed at the 1440 super resolution while the other was at 2880. As you can see there is a substantial difference.

Once again, THANK YOU VERY MUCH for your assistance trying to figure out this issue. I appreciate it very much and that is why I have been an InkJet Mall customer for ~15 years.

If there is anything else you can think of, please let me know. I will let you know what I find out from the Epson Repair Center.

Have a great day.