R3000 New Chip Not Recognized

printer

#1

I have an Epson R3000 that I’ve been using refillable cartridges with. The LLK cartridge was not being recognized. Realizing that I’ve had the cartridges for a while, I figured that battery died (it happened to one other cartridge in the past). I decided to order new chips for all the cartridges.

I replaced the LLK cartridge chip and not knowing if it needed the reset, I reset the chip by shorting out the two contacts with a paper clip. The cartridge still wasn’t recognized.

I tried the same procedure with a recognized cartridge, the C cartridge. When I put the cartridge in with the new chip, it wasn’t recognized. I put the old chip back on and it worked fine.

I next tried replacing another chip but this time, I did not reset the chip. The new chip was recognized. I did this for the remaining cartridges and they were all recognized.

So obviously, I should not have reset the LLK and C chips as they are the only two that are not being recognized. Why did this happen? And is there any way I can get them working again?


#2

This is a strange experience. I don’t believe reseting a new chip before reinstalling the cartridge into your printer would have effected the chip, or caused it to not be read by the printer. Have you tried removing + reinstalling the LLK cartridge, and/or shutting down your printer for a few minutes? So, the original C chip is working fine, but you don’t have a good working LLK chip, and all others are working fine?

Please let me know so I can help you past this and back to happily printing.
Best regards~ Dana :slight_smile:


#3

Thanks for your reply.

I did remove and reinstall the LLK along with shutting off the printer. It made no difference.

I ended up using the original C cartridge and that worked. With the LLK, I replaced just the battery and now that cartridge works. So I’m up and working now.

I can investigate the new C cartridge as that was one of the the two I tried resetting before I used. I can see if there’s any power in that battery.

I do agree that resetting the chip before using shouldn’t kill the battery. And it’s too much of a coincidence that the two chips that were dead on arrival, are the two that I tried resetting. It doesn’t make sense.

Thanks again,
Leon


#4

I’m glad you’re up and running after replacing the LLK battery. Please do keep me posted with what you find, if you have questions, or there’s anything else I can help you with.

Best regards~ Dana :slight_smile: