R2880 cart reads empty - won't reset

r1900
r2880

#1

I have an Epson SPR2880 that I usually use for printing with MK but I’ve got a job that I need to print with PK. When I swap out the carts the PK cart reads as empty and the printer won’t let me swap inks. I’ve tried to turn the printer off and on, I’ve uninstalled and reinstalled the printer and i’ve tried to swap carts back and forth multiple times. Is it a faulty cart? Would a chip resetter fix this?

Tech stuff:
Mac Pro running OS X 10.8.5
Epson SPR2880
ConeColor Inks and carts
All drivers and software up to date.

BTW: The printer is a workhorse and runs all day every day as long as I don’t need to swap carts, then it turns into a PITA.


#2

In order to switch between MK and PK carts/inks in your R2880, the chip on the different black cartridge that you install must read full or nearly full in order for your printer to accept it and do a black ink mode change. If you have been using MK ink, then install a PK cart that is previously used, and the chip reads less than about 1/2 full- the printer will determine the cart doesn’t contain enough ink to preform the black ink change, and the printer won’t accept the cartridge.

If your PK cart chip is reading too low for the printer to accept it and do a black ink change, then you can manually reset the chip to read full again using a chip resetter. The chip resetter you’d need for a R2880 is:http://shopping.netsuite.com/s.nl/c.362672/it.A/id.5752/.f?sc=11&category=27717

I hope this helps. Please let me know if you have further questions or there’s anything else I can help you with.
Best regards~ Dana :slight_smile: