Quadtone Rip does not save split tone setting

The printer dialog box in Quadtone rip does not save the fact that I am attempting to do a split tone print. No matter how many times I check the split tone box and have listed two inks and set their ratios the check mark and hit save it does not get saved and the print is done using only one ink set not two.

Plus sometimes quad tone rip does not do what it’s supposed to do, that is slowly print at 2880, unidirectional, and instead just speeds through the print leaving a very light print.

The only fix for this last issue is shutting down the printer and the computer and then restarting both.

Imac 5k 27inch, 128 Gig Ram, Quadtone 2.7.9, Mojave 10.14.6, epson 9900

Hi Brian,

First, have you already tried reinstalling QTR?

Next, it sounds like you are trying to save a setup by clicking Save in the Print-Tool Page Setup dialog. That won’t do it in my experience, sometimes not even when you go directly to Run Print. I don’t know why. What you need to do is save your setup as a Preset. Click the up/down arrow in Presets, select Save Current Settings as Preset, give it a name and click OK. Make sure that Preset is selected after clicking Run Print, before clicking Print. This has always worked for me as long as the printers don’t get wiped out as sometimes happens with an OS upgrade. (Just working on that today after upgrading to Big Sur recently. Still have a backup drive on Mojave just in case, but all seems to be working well so far.)

Finally, I’ve sometimes experienced something like your description of the printer just running with random settings (or maybe no settings). Fortunately, it has been very rare and always resolves itself somehow without any intervention on my part that I can remember.

But seriously, reinstalling QTR does seem to resolve most QTR related problems. If you have installed any other software recently, or an OS security update or anything like that, it is worth a try.