QTR and OS X Mavericks


#1

I just installed OS X 10.9 “mavericks” on my machine and had to reset my printer and scanners in the system preferences.

Now I’m unable to reinstall the QTR printers. Bleh. The terminal window is saying this:

“ALERT! **** QuadToneRIP does not support printer 9880 ****”

I’m getting the same error for my 3880. This is for both K7 inks and UC inks.

Any thoughts???


#2

Just to be clear, the printers aren’t showing up as options in the printer driver boxes (either photoshop or the QTR print tool). So I’m trying to run the install command in the QTR printer folders. To no avail.


#3

As an update, I reinstalled QTR and tried to install the printer again and got this:

"/Applications/QuadToneRIP/Profiles/7880-9880-K7/Install9880-K7.command ; exit;
DEBUG: load_classdriver(/System/Library/Printers/Libraries/USBGenericPrintingClass.plugin) (kr:0x00000000)
DEBUG: load_classdriver(/Library/Printers/EPSON/CIOSupport/EPSONUSBPrintClass.plugin) (kr:0x00000000)
Creating printer named: Quad9880-K7

Installing QuadToneRIP Curves Printer Quad9880-K7
Couldn’t open /etc/cups/ppd/Quad9880-K7.ppd for reading: No such file or directory
logout

[Process completed]"

I gather this is a QTR vs OSX 10.9 thing, which means I just have to be patient, but I’m posting it here and on the QTR yahoo group in case I’m just missing something obvious.


#4

Garie,

We can not support QTR of course. It’s not our software. Roy Harrington is your source of support. The QTR users group may soon be abuzz over Mavericks.

But, to give you some perspective…at Cone Editions Press we have still, a blue and white Mac running OS9 which connects by SCSI to a Hell 3400 drum scanner. There is no support for this drum scanner beyond OS9 by Linotype Hell. We have an old OSX 10 version computer which runs a certain version of software that includes a Firewire to SCSI adapter so we can run it at 14bit. Those two systems are forever frozen or we have to ditch the drum scanner - and of course nothing compares to a Hell drum scan. So we keep them.

Our rule of thumb is to NEVER update an OS unless we verify first that everything we need runs on the new OS. Our preferred color management spectrophotometer has not been updated past 10.4.7 - on which it is last possible to run the DTP70 by X-Rite - so we maintain this OS as well. Always at the minimum, make a boot partition which you can revert back to. At this point you will need to be in contact with Roy Harrington of QTR. Hopefully he will have a speedy resolve for you. We will wait probably half the year until everything is worked out before updating anything to Mavericks. It is designed for the new Mac hardware. Every update is ALWAYS with its risks and Apple always tells you this in their fine print. They recommend you back up everything including the boot.

Even though we can not support QTR - logic says update your printer drivers and then try reinstalling QTR printer. We will be interested to know your experience and the resolve on this. Please keep us appraised of the situation!

Jon


#5

Jon, Roy posted a temporary solution/work-around over at the QTR yahoo group. It’s basically manually creating a Quad printer via the instructions on the last few pages of his tutorial.

It worked for my 3880 using OEM inks, but unfortunately I still can’t get the 9880 K7 curves installed. I do know you guys don’t support QTR, but it is the software that drives your product, so I figured this was as fine a place as any to ask for ideas.

And yes, thanks for the advice on updates. Of course, I’ve a backup computer I can print off in the meantime.


#6

Jon, I figured it out. The K7 curve install was hanging up on a Canson Rag Photographique profile you guys had given me. I’ve no idea why it was having trouble with it, but I just repasted the first line of the curve (the inkset line) in and resaved it and then the curves all installed fine.

So, with that, up and printing again. Really easy thanks to Roy explaining the manual adding of the printer.

Conclusion is QTR and piezo do work with 10.9. Just have to reinstall QTR and manually create the printers in the system prefs. Takes about 10 minutes.