Pro Curve for CRP on R2880

There isn’t a set of Pro curves for Canson Rag Photographique on the R2880 in the Community Edition 2.04. A surprising omission. There are Pro CRP curves for the 3800, 3880, 4800, 4880, 4900 and so on up the line.

What’s the best alternative starting point? The R2880 HPR curves or the 3880 CRP curves?

Also, I can’t download the latest version (3.02) of the Community Edition from Piezography Community Edition | Piezography - I get presented with a login page for PiezoDN and PPE users. The change log doesn’t suggest that much has changed since 2.04, but even so, I didn’t think that this was supposed to require a login to download.

yep, the maintenance guts are going.

best regards,

Walker

Eh? Was this supposed to be a reply to my R1900 death rattle thread?

woops! my browser cache messed that.

Odd. The questions in this thread are still active.

Hey Brian,

No problem here for downloading from your link, though the latest version is 3.03, so maybe you are seeing a cached version – try refreshing the page.

Keith

1 Like

I can now answer my own two questions.

  1. The best starting Pro set of curves for both CRP and EEM on an R2880 - both of which are missing, which really surprises me - is HPR. Which is not a surprise. HPR is usually a good generic starter curve. However the 3880 set of Pro curves for CRP are not a good starter for the R2880. Which does surprise me a little, as 3880 curves were remarkably good for P2 on the R1900 once remapped, but I guess the structure of Pro curves is different and they don’t migrate across printer models as well.

  2. Thanks @jkschreiber for testing out that download for me. I’ve worked out what happened. For the Windows download, the “Download” button works, and worked for me today. So I now have the file. However last night it was slow to start the download for some reason and so instead I kept clicking on the “Piezography Community Edition Windows” text link. This link is wrong and takes you to the login page for something or other. @walkerblackwell - I suggest you fix this link.