Printer sharing headaches with 10.14.5. Anyone else?

I’m asking here because my setups are very similar to what’s used in the classroom at Cone Editions. Mac Mini server. Epson printers connected via long USB cables (thanks Walker!). Client computers on the same local ethernet. All has worked wonderfully for years. With everything on 10.14.5 (server and clients), I can no longer connect to shared printers. I have been able to connect a few clients with earlier systems (10.14.4 or 10.13.x) to the 10.14.5 server

I’ve tried every connection protocol that I can think of. Usually simple Bonjour connections work well. Now… at the last step and actually setting up the connection I see an error message that the printer can’t be verified on the network. If I click continue anyway it seems to be setup correctly but efforts to print never get to the server at all. I’ve tried MANY command line options using lpadmin as well. No go.

Printers involved (latest drivers stated as 10.14 compatible) are 4900s and a p6000 and p8000. Epson driver only at this point. No QTR


Thank you!

Bob Smith

Me thinks your network is isolating the server ip somehow. Check with your admins to see if anything has changed security wise.


I’m seeing the same thing on my personal studio network as I am on the University network where the system described above is located. Everything in both cases is on the same subnet. I took my studio server and computers up the 10.14.5 to try and help diagnose this issue. I’m going to strip things down further in my studio this weekend to try and isolate things.

Can you confirm that you have a 10.14.5 client printing to a 10.14.5 server?

Note… we have an HP Color Laserjet on the same server. We have been able to get connections to it to work… not to the Epsons. The HP is on ethernet, not USB, but it is shared the same way on the server as the Epson’s are. The HP is setup in such a way that only the server can reach it’s IP address. Printing has to go through the server to reach it… and that is working.


It seems to be that USB printer sharing is broken by either Epson on Apple on 10.14.5. Connecting the printer to the server via TCP/IP and sharing works perfectly normally. Simple connection using Bonjour GUI. No command line needed. Same setup with printer connected by USB and shared won’t work under any circumstances that I can find.

Would love to hear from anyone with different experiences specifically on 10.14.5 for both client and server.


FYI, how to file a bug: Bug Reporting - Apple Developer



A completely clean erase/install of the system being used as a print server set everything back to operating in the usual predictable reliable way. Sharing USB or network printers works fine with usual Bonjour connections.

I had been testing with three different “servers” all of which had been upgraded to 10.14.5 from 10.12.6 machines. All had similar problems. All had their print system “reset” and all Epson components wiped and reinstalled many times. Most of my client computers (in a college art lab) were completely clean new installs of 10.14.5 along with the latest Adobe versions. After hours/days of frustration I tried using a fresh client computer as a temp server. Worked like a charm instantly. Erased the real server completely and installed fresh. Problem solved