Please help with my clogged yellow nozzle

inkthrift

#1

I’m using an Epson 3880 with the InkThrift inks. Could you tell me how to unclog the nozzles? I’ve already done a power clean and it is still clogged.


#2


this is the printout


#3

[QUOTE=Lonnie;1335]I’m using an Epson 3880 with the InkThrift inks. Could you tell me how to unclog the nozzles? I’ve already done a power clean and it is still clogged.[/QUOTE]

Tried the capping station technique and it worked. I’ll start cleaning that regularly from now.


#4

Hi Lonnie~

I recommend cleaning your printer’s capping station, wiper blade and bottom of the print head, which you can find instructions for here: http://www.inkjetmall.com/tech/content.php?133-Printer-Preventative-Maintenance

Hope this helps, please let me know if you have questions, how things go or if there’s anything else I can help you with.
best regards~ Dana :slight_smile:


#5

Excellent, I was just about to recommend you try that. Glad to hear you fixed your own problem by cleaning your printer.

Best regards and happy printing~ Dana :slight_smile:


#6

[QUOTE=Lonnie;1337]Tried the capping station technique and it worked. I’ll start cleaning that regularly from now.[/QUOTE]

I’m a little late, so I hope you see this… (I may be in the wrong subforum, but I thought my issue fit the topic here. Please move it if I’m in the wrong place!)

My K cartridge is clogged on my 1430. The pattern does not change from day to day. The other five carts are fine. I’m using Inkthrift CL (capsules and keys).


Can you tell me what the capping station technique is? I’ve seen Dana’s video on cleaning a 1400/1430 - is the technique in this video? or somewhere else?

Thank you!

Paul


#7

Check out this page: http://piezography.com/print-head-cleaning-tips

Videos at the bottom as well,
best,
Walker


#8

Thanks Walker, I printed out Tip #2 for easy reference as I went through the steps. I did all the steps (sponge pad, rubber gasket around pad, wiper blade) as carefully as I could, but my K cartridge pattern remains exactly the same. In fact, the magenta position nozzle check is now showing gaps as well. I thought maybe that cart was low but it doesn’t show as low in the ink level diagram. All carts are about 1/3 full. And the InkThrift CL EasyFill key does not have a transparent side for a visual check.

Before reading this document I had performed an underhead cleaning (aka shoe-shine). I was gentle but I hope I didn’t scratch the head’s under surface with a portion of the paper towel that was not soaked in Piezoflash. Is there any way to check that?

Any suggestions as to how to proceed would be most welcome…

Thank you!

Paul