PK cartridge on Epson 9600 in print driver shows up as MK


#1

Help,
My Epson 9600 is showing the Photo Black cartridge as being Matte Black - it states that it is the wrong combination of inks when I try to profile papers. I’ve gone into the maintenance mode of the printer and changed it there, but the printer then states it is the wrong ink. I’m trying to profile paper and I can’t get it to work until the cartridge is reading as PK. I’ve even put the PK flush cart into the printer with the same results. Could I have been sold two PK cartridges that are actually MK? I’m printing color now, in the past it was used for Piezography and had no issues - it has printed color with these cartridges in the past also.

Any help would be greatly appreciated.
Paul


#2

If you boot into maintenance mode you can reset the printer and it will boot up and accept the PK.

How to change from matte black to photo black without wasting money and ink

How to change the photo/matte ink in the Epson 7600 and 9600 printers without using the costly Epson draining procedure:

1 - Make sure your printer is switched OFF!
2 - Open the ink cartridge lever in the ink cartridge bay
3 - Replace the photo black cartridge with the matte black cartridge (or vice versa)
4 - Leave the ink lever open !
5 -Using the printer control panel go into Maintenance Mode 2 by switching power ON while pushing the ‘Paper source’, ‘Cut/Eject’, and ‘Paper Feed down’ buttons.

PRESS TOGETHER

6 - Press the ‘Paper Feed down’ button until you see “SERVICE CONFIG” on the display - press the
’arrow right’ button. It then shows ‘XXD’ in the lower part of the display.

VIEW COUNTERS

SERVICE CONFIG

SERVICE CONFIG - XXD

SERVICE CONFIG

7 - Press the ‘Paper Feed down’ button until you see
"NPD" - press ‘arrow right’ button.

NPD
7a - A value of ‘1’ appears in the display.

NPD *1

8 - There are 3 possible value settings for NPD:

0 - no ink check
1 - pigmented ink (there should be s star “*” at this setting)
2 - dye inks

9 - Change NPD setting to ‘0’ (no ink check) by pressing the ‘Paper Feed up’ button and press
"Enter" - a star should now show next to the ‘0’ value

NPD *0

10 -Switch printer off

11 - Switch printer on

12 - Close the ink lever in the ink cartridge bay

13 - Printer and driver shows the matte black ink is installed (or photo black ink)


#3

Hi,

Thanks for responding. I did all of that, several times and the printer flashes all the ink lights and says it’s the wrong ink. I’m starting to think that both of the PK cartridges have the wrong chips in them, even though I did have color in them before and profiled papers. The only difference is the computer and probably a newer driver.

Thanks,
Paul


#4

Seems to me like you have an MK chip. Just get a PK cartridge, take the chip off and put on your current cartridge and do the procedure above.

best,
Walker


#5

Does Inkjet mall sell the chips?
I purchased both of the PK cartridges from Inkjetmall.

Thanks,
Paul


#6

If this is a PK cartridge and your printer is saying “ready” just delete your printer in system preferences and re-add it. It should switch over to PK.

best,
Walker


#7

Ok, I’ll try that.

Thanks for the help!

Paul