Photo black stopped working


#1

I had a problem with the photo black yesterday.After printing normally for 20 8x10 the photo bk refused to work.Did a test pattern and not a single line appeared.Did a cleaning and same result in the test.No lines was visible.I repeated the process once more and same result. Then i decided to use an Epson original cart and after a couple missing lines in the test the printer resumed its job.It seems the cart is not delivering ink any more.What’s wrong?Regards Andre


#2

Is this the 1st cartridge you have replaced with Inkjetmall Carts? Did you remove the Air vent plug? This is a common oversight and will cause air to enter the lines and won’t allow ink to release from the cartridge.


#3

of course that I removed the vent plug.I have 5 carts working fine and the photo black seems to be dead.I will have to replace it with a new one.I do not see any other way to get rid of the problem.


#4

OH, you didn’t indicate you were printing successfully with the other cartridges you ordered, so I had to cover the bases. This is more common then one would think, I didn’t intend to insult your intelligence, I apologize if I did.

I will send you a new cartridge in the mail today, Please let me know your problem has been resolved after receiving it. You may have air worked into the lines and it may take some extra CC’s to get it all out.

Another suggestion would be to perform some cleaning on your Capping Station, Wiper Blade and Bottom of print head, this is always a good habit to get into at least 2x a year with the 3880.
Kindly,
Kelly