Photo Black cartridge not recognized in 3880

printer

#1

I am using Warm Tone inks in my 3880. Now the Photo Black cartridge is not recognized by the printer. Also it is very difficult to remove from the printer. It takes several tries before I can pull it out. The last time I had this problem Inkjet Mall sent me a new chip and I did print for several months. I tried inserting the original Epson cartridge and it does not work either. I have tried all your suggestions to reset the printer, turn off the printer, remove the waste ink pad, etc.
Should I just buy a new Photo Black cartridge? I do not have a chip resetter for the 3880 but do not know if that is the problem. I never used one before.
Thanks for your help.
Catherine Costolo


#2

Hi Catherine~

Occasionally, the printer’s locking tab can get stuck on the locking notch on top of the carts, so they don’t pop out easily. In this case, if you lightly hold down or tap the locking lever while gently pulling the cartridge, it should slide right out.

After reviewing your order history, I see you originally ordered the 3800 refill carts in 2012, and we sent you a new MK reset chip last November. This model 3800/3880 refill cartridge doesn’t use a chip resetter for cartridges, but the reset chips that come on the carts (that get an Epson chip placed below), are what control chip ink level reset. There is only a chip resetter for the waste ink tank, which I see you have.

What is the exact message displayed on your printer’s LCD panel?

Please let me know so I can help, thanks~ Dana


#3

The message on the LCD says, “No ink cartridge” and “install ink cartridge”.
Catherine


#4

Thanks for the additional information.

Please check the PK cart- is the chip raised up? Did you forcefully install or remove the PK cart recently? Remove the PK and MK carts from the printer, and look inside the cartridge chambers to visually compare the chip sensors, which are located on the back/top of the cartridge chamber. If the chip wasn’t attached flat/flush on the PK cart, and the cart was forced in or out of the printer, this could have caused damage to the chip sensor, which is made of very thin wires, that can be easily bent/damaged. The wires need to be bent in a specific way to have proper connection with the chip contacts.

If the printer’s chip sensor looks good (the PK and MK look the same), please check the chips on the PK cart, following the instructions below.

[B]38XX “80ml” refill cart reset chip check:
[/B]The plastic base of every 3880 reset chip should have three small plastic tabs around the side that hold it onto the cartridge. If any of these tabs are broken or bent inward, the chip will not stay secured to the cartridge, therefore not have a good connection with the Epson chip underneath, which will cause an error. Also, on the back of every reset chip, there should be three metal pins that stick out and touch the Epson chip- the three pins should be equal length for proper contact with the Epson chip. Please check the plastic base to make sure there are three plastic tabs, and if they are all in place, gently bend them outward slightly to ensure they catch and hold onto the cartridge. Also check to make sure the three metal pins are present and equal length. On the front of the chips, please check the gold contacts to make sure nothing is on the contacts that would interfere with the printer’s ability to read it- if you see anything on the gold contacts, gently clean them with either an alcohol pad or pencil eraser. After checking all these things, push the reset chips back onto their corresponding cartridges and make sure they are pushed all the way onto the cart for a good connection with the Epson chip, then reinsert the cartridges into your printer and see how the printer responds.

I hope this helps, please let me know what you see, and if you have questions or there’s anything else I can help you with.
Best regards~ Dana


#5

Dana, I have checked the PK cart.The chip sensors inside the cartridge chambers seem to be fine with no damage. The metal pins seem fine and I cleaned the gold contacts with alcohol.
It appears to me that the chip does not want to lay as flat as the chip in the MK cartridge, especially now after I removed it and tried to replace it. I am not clear about the tabs you mentioned because I do not
see those. Maybe I am not looking in the right place.
Maybe the best idea is to get a new PK cartridge.
Thanks for your help.
Catherine
Dana, I am not certain the MK cartridge is working correctly either. Sorry I am confusing things.


#6

Thanks for the additional information Catherine. It may be the PK reset chip isn’t making good contact with the Epson chip underneath, and that’s causing your error (?)
I’m glad to hear the printer’s chip sensors look good, and aren’t damaged. If we’re thinking it’s the PK reset chip causing your error, then you can get just a new PK chip, and not a whole new cart. Chips can be found here: http://shopping.netsuite.com/s.nl/c.362672/sc.18/category.122640/.f

I hope this helps, please keep me posted and let me know if you have questions or there’s anything else I can help you with.
Best~ Dana