PBK Cartridge Shows disconnected (Flasking Icon) (Stylus 7880)

I am trying to do a Piezo-Flush and when starting the 7880 after having replaced the ink cartridges with the Piezo-flush cartridges, the PBK position shows it disconnected.

I tried the following:
Wiped the chip clean, Reset the Chip, wiggled the Cartridge, placed a cardboard shim under the Cartridge. I tried all of these multiple times.

I am about to head to the drug store to get some long swabs that will reach the Printer’s Contact Pins so I can attempt to clean them.

Would you advise me about what to do?

I have tried to add a few pictures, but I’m not sure they have uploaded.

Darrrell Piezo Image-3_1-9-21.jpg
Darrrell Piezo Image-2_1-9-21.jpg
Darrrell Piezo Image-1_1-9-21.jpg

Hey, sorry for the late reply. Can you look in there and look at the copper wire sensor pins (top right of the ink bay). If one is mangled this will happen. This can happen if a cart is inserted with the chip missing. It can also just happen as the sensors on these printers are very fragile. The CSIC sensors can be purchased from compass micro for a few dollars but need to be replaced by removing the ink bay and getting in from behind.


I have three cartridges:

  • MBK with Piezography-Pro Matt-Black, This works
  • PBK with Piezo-Flush, this doesn’t work
  • PBK empty, this doesn’t work

The picture below is fuzzy, but the contacts look pretty good to me.



Dear Darrell, can you re-upload? The image is not here.


Darrrell Piezo Image-1_1-11-21

It’s too blurry in this photo but this is the area you need to look at:


I haven’t found any long swabs yet. Once I find them, I will clean the contacts.

Is there a difference in the Chips between the MBK and PBK Cartridges? Should I buy a new MBK Cartridge?


MK and PK are specific. All the other colors are interchangeable.

best regards,