P600 not recognizing PK CISS Cartridge

I have a Surecolor P600 and have been using the CISS for about a year now. Tonight all of a sudden the PK Black cartridge is not being recognized. I can switch to MK Black, but then not back. I tried to put in an Epson PK Black cartridge to see if that would reset the system, but that did not work. Any suggestions to get the PK cartridge recognized?

I assume you turned the printer off and back on too? Did that do it?

There’s a little warning about these carts. You don’t want to pull these when the ink cover switch is in the printer. If you do, it can short out the chip. Did that happen?

Also, these chips are sensitive to static or power surge. I suggest putting the printer on an APC or power conditioner of some sort. Please let me know the process leading up to the cartridge chip problem (was it low, etc, before). I will private msg you for replacement if we can’t resolve it directly.

I also suggest a backup set of P600 chips for anyone who has this printer. We will have these in stock at some point very soon.



Thank you for your reply.

I have turned the printer off and on and that did not make a difference.

Here is process that lead up to my issue:

I printed one photo with no problem.
I printed a second photo and noticed I had no deep black.
I ran a nozzle check and there was no output from PK head.
I did a Head Cleaning and the same. No output from the PK head.
At this point, I received the error message that the cartridge was not recognized.
I did a transition to the matte black cartridge to see if it was working. The Head check showed it was fine.
When I tried to go back to the PK cartridge I got the error message again.
I put in an Epson PK cartridge and was able to transition back to Photo Black.
I put the CISS PK cartridge back in and still received the error message that the cartridge is not recognized.

The printer is on a surge protector.

Please let me know when the P600 back up chips are available.

Ocassionally, I get the error message on other cartridges, but when I take out the cover pin and replace it, the error message usually goes away. Sometimes I have had to tell the printer to proceed with the non-Epson cartridge.

Thank you very much for your assistance with this. The service from Inkjetmall has been outstanding in the 10 years I have been a customer. I have recommend you to several members of my Camera club and photographic associates.

Have a great day.


Ok. So the error message comes up when the chip resets to full so you are doing the correct procedure by just pulling the cover switch and putting it back in.

I will work on getting you a PK chip. For now keep the OEM PK in.


Thank you!!!


So, I’m having a similar problem with my p600. But this is from a brand new install of the kit
I ordered a kit last weekend and it arrived late this week and I’m just setting it up today.
No reset chip was sent with the kit.
I’m on a Mac, so I’m following those instructions.
I’ve filled and installed the 9 cartridges in the p600.
I’m ready to start printing (expelling the old color ink), but found that I didn’t receive anything to help close the ink bay door (so the printer knows it’s closed). I currently using a plastic spork to get the printer to think that the door is closed and now get the following message:

Cannot recognize the following ink cartridges . . . (it’s the last 2 cartages specifically).

I’ve looked up this error here and read about what it might be, but I’m not really getting this fixed based n what has been posted. For instance, I haven’t pulled any cartridges while the door was technically closed (IE I don’t think I fried any of the chips). I’ve tried turning the printer on/off and back on again. Same error. What else can be done?

Please advise.

Also, no gloves sent with kit either.

Dear @JTAllen I’m cc’ing @Wells to get you a replacement cartridges. You can take the chips off and snap onto your CISS carts.

When he emails you let him know the chips that aren’t working.