"No Ink Cartridges" Error on Epson 3880

I am using Inkjet Mall EP38XX refillable cartridges on an Epson 3880. Printer recognized all cartridges just fine, turned printer off, the next time I turned it on, printer reads “No Ink Cartridges” on front panel for every single cartridge.

I’ve taken out all cartridges and reinserted them, I get the same error every time. Printer will not let me run a nozzle check or head cleaning because the cartridges are not being recognized at all. What’s going on?

Epson Stylus Pro 3880
iMac Pro
System 10.14.6

There is most likely 1 cartridge that has a loose contact between the OEM chip and the control chip. The control chip may be sticking up a bit too far and needs to be taped down over its back solder points.


Ok, thanks for your advice, Walker. I’ll double check all the cartridges for contact issues.

I am experiencing a similar problem.

I have just installed all new cartridges with new K7 inks in my Epson 9890. I set everything up, did a few nozzle checks and cleanings and quickly got perfect results. I then did some test prints of target grey scale images, and everything worked perfectly.

The next day I started the printer up to try a first actual print. The control panel indicated no cartridge in the LLK position. I tried reinserting it a number of times with no luck. Then I installed the corresponding cartridge from my PiezoFlush set, the printer worked normally and I got a perfect test print.

I am wondering if you have been able to solve this problem on your 3880?

If you have any advice, please share.


Hi, Blair,

I feel your pain!

In my case, I had done everything you mentioned, including reinserting every cartridge multiple times. It wasn’t until I took out each cartridge and pressed hard on the cartridge chip of each one that the problem got resolved. Apparently, the connection of the chips to the cartridges had loosened over time, so that the chips weren’t making proper contact when inserted into the printer. Pressing hard reattached it to the cartridge so that it was in the appropriate spot. I should add that the problem was so subtle that I couldn’t tell just by looking at it that that was the issue.

But that solved the problem, and I have been printing happily ever since. I hope this works for you!