Looking for troubleshooting advice Epson 7800


#1

I’m troubleshooting an Epson 7800 that won’t print (anymore). I’ve read a few posts here and also some other info on other sites but I thought I’d ask as well. I’m this close to scrapping it but before that - here’s the deal…

I work for a school and was given two 7800’s form the printmaking dept. in various states of repair. One worked ok, and on the other I replaced the wiper, flushing box and dampers. It still wouldn’t print, so I pulled out the main board and found a fuze was blown. Replaced the fuze and all was well until (it printed beautiful!) until I ran a piece of coated aluminum through and it got caught on the head. After that, it’d go through the motions, but it wouldn’t print.

I tried replacing the fuze again but no luck. I took the head out and replaced it with another from a 4800, also no luck (both heads work in the 4800.) I replaced the cleaning pump assembly and it seems to be pumping (I took one out of a a functioning 7800 and when I ran it on the 7800, leftover ink was sucked through.) I also put in a motherboard I knew was fully functional but still, nothing prints. I replaced the cable running from the head up to the top, too, and still no dice. (It’s not OEM, but from Ebay so maybe it’s faulty?)

The ink doesn’t seem to be moving to the cartridges at all - could it be a suction problem, that something shorted out? Or another fuze blown somewhere? (There are so many.) I have the maintenance manual but I couldn’t quite tell what to look for next.

Thank you very much for any advice!


#2

I think when the head got caught it messed up the ribbon cable connection. You most likely need to replace both the ribbon cable going to the head and the head.

best,
Walker


#3

Thank you, Walker! I’m sorry, guess I wasn’t clear, but I do have a new data cable and a “new” head pilfered from an Epson 4800 (It works in the 4800.) Maybe the new data cable I bought is a dud, as it was 3rd party and pre-folded. I’ll try again with a different cable and cross my finger that it works. (I have a non pre-folded one around somewhere…I’ll give folding a go.)