Linearize The Quad

On a Mac system (os 10.14.4) I have successfully made a 51 step target and saved it as a measurements.txt file with no errors following the directions carefully. Placed it into the QTR Profiles folder and dragged it and the .quad file I wish to linearize int the QTR-Linearize-Quad droplet - all inside of the QuardToneRIP - Profiles folder. The result is he creation of a measurements0out.txt but not a new “…-lin.quad” file. I have checked permissions and I see no obvious issue.

While it has been a few months since I last created a new quad file, this has worked in the past. All suggestions are welcomed.

When you say “checked permissions” did yu check permission on the folder?

Copy/paste the files to another folder in your Documents folder and re-do and tell me if you see the -lin or not. If so, the permissions were an issue in your original folder.


Walker - thank you for your rapid response.

I checked the permissions for both the app and the folder - both looked good

copied the measurements.txt and the .quad file to a new folder in Documents. Copied them from there into the that was still in the QuadToneRip-Profiles folder. - result was nothing. Copied the into the same folder in Documents and tried again - nada.

to clarify - the method suggested resulted in a measurements-out.txt but not a “…-lin.quad”

Sometimes when this happens there is a message at the end of the -out.txt file that either identifies the problem explicitly or gives a reasonably good clue. Did you look at the -out.txt file and did you see anything like that? If so, copy/paste it here.

PIEZOGRAPHY-out.txt (4.6 KB)

Oh well - no luck there. The other weird thing I can offer is that there have been a few times when I swear there is no new -lin.quad created but when I look again later I find it right where it should be - I have no explanation for this other than gremlins.

~ Keith

Gremlins…thanks for your help Keith

Hi Walker,

After more thought I remembered that I have updated the MAC OS since I last made a new quad file. I also tried the process on my Mac laptop (also running 0s 10.14.4) with identical results - the measurements-out.txt was created but the new quad file was not. The same result occurred regardless of what folder the files were in.

Please upload the measurement zipped txt and quad file or screenshots or something.

I really can’t help until I see some stuff like that.


Hi Walker,

this is the screen shot. I attached the measurements.txt file

Screen Shot 2019-05-05 at 11.44.05 AM.png

PIEZOGRAPHY-out.txt (4.59 KB)

That’s not the measurement file. And I think you misread my attempt at humor above, but I apologize for trying to help.

no worries Kieth - my thanks is sincere. made me laugh.


Hi Walker - this is the measurement.txt file made from scanning the 51 step target.

FWIW, I just tried this with your measurement text file and a random quad curve, from my desktop and from within a Curves>[printer] folder, and it worked in both cases so there is nothing wrong with the file. I am still using 10.13.6, so perhaps it’s a Mojave permissions thing. I did try Mojave for about a week a few months ago, but reverted to High Sierra because of a few annoying little incompatibilities, though I don’t remember if this was one of them.

Hi Keith - thank you for trying it!
I think that it is a permissions thing with Mojave as well - just a best guess, but I can’t seem to figure out how to fix it. The results are very consistent.

Ok. So there may a bug with your particular tool.

The interim solution is to copy/paste the data (select all copy) into a new txt file in sublime text or some other text editor instead of saving the sheet as a tsv/csv (txt) file. I have validated that this work.

This with how Google/chrome downloads Sheets I think and I think it’s related particularly to your tool so I will rebuild your particular tool.

Also, I do believe as a workshop attendee that you have access to PPEv2. I resent your credentials for that so you should see it in a bit in your inbox.

Full calibration tutorial for PPEv2: About Piezography Professional | Piezography


Hi Walker,

Something changed for sure. I appreciate your help and have downloaded PPEv2.

1 Like