Issues With Changing Colors

inkthrift

#1

Hi, so I’ve been having some issues with the InkThrift cartridges I’ve purchased for my Artisan 1430. When I first received the inks I replaced my spent Epson cartridges with your black, light cyan, light magenta, and yellow (leaving the still half full Epson magenta and cyan cartridges in the printer) and everything was printing as it had with all Epson cartridges. A few weeks later I replaced the then-empty Epson magenta and cyan with your product. Unfortunately when this happened the color settings were completely off. My black and white images are coming out tinted yellow and magenta. The pure black backgrounds are dull yellow. No print or color settings were changed, all of the cartridges were more than half full, I reinserted the cartridges to make sure they inserted properly. No dice. I replaced the InkThrift magenta and cyan cartridges with Epson cartridges, and once again my blacks were black, though there was still a color shift that wasn’t there before switching them out in the first place. I’m not exactly sure what is going on here, any help would be appreciated.

White background - All Ink thrift cartridges
Black background - Epson’s magenta & cyan, InkThrift for remaining cartridges
Bottom image- Original image



#2

Thanks for the detailed info Kate.
What you’re experiencing is very strange. Have you printed nozzle checks at these various points to make sure all inks were fully printing, and in the correct order? Can you please attach a printed nozzle check with all InkThrift carts installed? Are you printing from Mac or Windows? What operating system? What printing application and version are you using? What paper(s) are you printing on?

Please let me know so I can help resolve this for you.
Best regards~ Dana :slight_smile:


#3

[QUOTE=Dana-IJM;4279]Thanks for the detailed info Kate.
What you’re experiencing is very strange. Have you printed nozzle checks at these various points to make sure all inks were fully printing, and in the correct order? Can you please attach a printed nozzle check with all InkThrift carts installed? Are you printing from Mac or Windows? What operating system? What printing application and version are you using? What paper(s) are you printing on?

Please let me know so I can help resolve this for you.
Best regards~ Dana :)[/QUOTE]

Sorry for the late reply, I’ve been on vacation.

Unfortunately it seems like the cyan and magenta aren’t printing, it’s hard to see in the photo, but the yellow is showing up fine. I didn’t check before I switched them out, but as the color was fine I assume they were working properly.

I’m on OSX 10.9.2, I’ve used a variety of papers but mainly use Epson’s Ultra Premium Luster


#4

Thanks for the update Kate. The fact that two channels aren’t printing would certainly cause your print output to look strange.
Please make sure the cartridge air vent plugs are removed, and air vents open for proper ink flow. You should make sure all channels are fully printing on the nozzle check before printing images, for the best results.

Keep me posted, thanks~ Dana :slight_smile: