Invalid ink cartridge

4000
4800
4880

#1

I tried to find if there were similar posts regarding my issue but did not find any. I have a 4800 and use the glossy Go set of cartridges with the #1 slot for matte. It has worked fine. I recently filled the #1 cart with warm neutral so it was contaminated. That cartridge was labeled PK on the outside. I ordered a new cartridge, reset the chip (showed green). The new cartridge would always register as invalid cartridge despite reset to green. So I thought it was a faulty chip. Wells is sending me a new chip. But much to my surprise I had two spare MK cartridridges in storage and could reset them to green but they also register on the printer as invalid cartridge. So, I think the chip may not be the problems

Any guesses what is wrong ? Wells is sending a new chip but I am beginning to think the chip is not the problem
Thanks,
Carl Quedenfeld


#2

You have essentially confused your printer into thinking it is going to be using PK without actually doing the Black ink Conversion, so it is now stuck in limbo.

You will need to purchase or borrow a Black ink conversion kit and install a OEM MK chip onto your refill cart. The Black Ink conversion procedure is covered in the Epson Printer User Manual.


#3

So I called Epson and they said I can buy a Black Conversion Kit from National Parts. Then I have to put these carts in all the slots and pull out all the Carbon K7 out ? or do I just replace the chip from the first cart ? Confused. I am willing to pay for tech support


#4

*UPDATE for anyone reading this thread: this problem was resolved via phone support (which we charge for).
Here’s what happened: The customer confused their printer by installing a Matte Black cartridge without first doing a black ink change, after they had successfully been using a Photo Black cartridge. To resolve the issue, he had to preform a black ink change (following instructions in the printer user manual and using the black ink conversion kit) for his printer to accept the MK cart- he’s now back to happily printing :slight_smile: