Ever seen this error message? - MK not working on 4880

4880
4000
4800

#1

My trusty 4880 went down in a weird way that maybe group members can help with. Two months ago I switched to a Cone Ink LLK. All well. I’ve been doing a large ABW job since then with good results. Then, as the matte black (MK) went down I ordered a (Cone) matte black cartridge and ink. I filled it, no prob, and installed it. That’s when things went wonky. (I did, of course, work through the ‘non-Epson’ dialog box in the printer control panel to get to the ‘ready’ state.)

First, the printer dialog box on the computer comes up, showing all ink ‘boxes’ in the readout (including the two Cone carts as different ‘blank’ icons. When I hit print, first I get the standard Epson warning screen about non-Epson inks, etc. That’s normal, and it showed both blacks correctly. Now, here’s the quirky part I can’t get past. When I click OK on the warning screen, it then shows the printer screen in gray and in front of it a box that says:

"The selected media type/print quality setting may not be compatible with the installed ink cartridge

Photo black/cyan/vivid magenta/yellow/ light black/ light cyan/vivid light magenta/light light black

Please check your new media type and print quality settings in the printer software."

Can’t get past that. Clicking OK just cancels the print box completely. Changing media settings and quality does nothing. When I go in ‘info’ in the utilities dialog, I see a small grayed out box with both photo and matte black types listed, with the bar over the photo (won’t move) type. But neither is darkened out and the box is unresponsive. Yet, in the main print setup, the glossy papers are grayed out, leading me to think the MK is recognized.
I’m totally puzzled. I ordered a new Epson matte black cart (the old 110ml one was sucked dry, even though it said it had 5%), and maybe when it comes it will fix the problem, by switching back. If that doesn’t work, I might swap chips from the Epson to the Cone cartridges. And suggestions? Thanks!


#2

Hi chaslewis2004~

What I believe is happening is the 4880 refill cartridge chips are programmed with all color position information (therefore they can be installed in any position, so always make sure you’re inserting the cartridges in the correct positions). This can sometimes cause the printer to get confused by reading both blacks when the printer is in MK mode (though it doesn’t seem to cause an issue when the printer is in PK mode for some reason). You should be able to get around this by attaching the chip form your original/empty Epson MK cart to the refill MK cart, then resetting the chip to read full again using the chip resetter. I have included instructions for attaching an Epson chip to your refill cart below. The most important thing is to make sure the chip is flat/flush + straight in the chip area of the cart before installing it into your printer (if it’s not flat, it can catch on the printer’s chip sensor and damage it).

Please let me know how your printer works with the Epson MK chip attached, if you have questions or there’s anything else we can help you with.

Best regards~ Dana

[B]Attach Epson chips to refill cartridges:[/B]
Before handling any chips (or really any electrical device for that matter), you should ground yourself and mindful of the clothing you wear, and if you’re working on carpet, etc… as static shock can destroy a chip.

Looking at the chip on the Epson cartridge, you will notice there are two small plastic points that hold the chip in place. Make a note as to which way the chip fits onto the cartridge so you can attach it to the refill cartridge in the same direction. Using a straight razor blade at an angle carefully cut the top of these two points off (be careful not to scratch the gold contacts), which will release the chip so you can carefully pry it off the cartridge using the edge of the blade. You can also use a sharp knife or something similar to pry the chip off the refill cartridge. You will notice the same two points on the refill cartridge where the chip goes (pry the chip off the refill cartridge before attaching the Epson chip in it’s place)- gently line up the Epson chip with these points and attach it to the refill cartridge by using single thickness (not foam or thick) double sided tape. Making sure your hands are clean and dry, press the chip to make sure it is tightly seated and [B]flat/flush [/B]on the cartridge. Now, using the chip resetter- reset the chip and insert the cartridge into your printer. NOTE: Installing a cartridge without a chip, or with a crooked chip attached can damage the printer’s chip sensor- so always make sure cartridges have chips secured flat before installing cartridges


#3

Here’s the latest. I put in a brand new, sealed Epson Matte black (T-6148) and like a smaller Epson cart I’d reset and refilled, the printer read “invalid cartridge.” So right now, Epson doesn’t work and the Cone cart is recognized, kind of, in some of the screens, but can’t get past the error message (my post above). I’ve tried all the media combos, and for sure the cartridge is in right (the fill holes can only be on top) and I’m dead in the water. This whole thing started when I ran low on an Epson cart and put in the Cone. The printer hasn’t worked since that moment. I can’t see much reason to pry the chip off the new Epson and stick it on the Cone, unless there is some thing I’m not understanding. Chip sensor gone bad that moment? Possible, but I really hope not. Further help would be very much appreciated. Thanks! Chas


#4

VERY strange! No, there’s no need to transfer the Epson chip to the refill cart if the printer is giving an error with the Epson cart… I don’t believe your chip sensor is bad- in my experience if a chip sensor is damaged, it doesn’t correctly read any cartridge chip, and consistently gives the “NO cartridge” error until the sensor is replaced. It sounds like your printer/chip sensor is reading the cartridge chips differently, but not as it should. I wonder if your printer somehow spontaneously changed it’s self to PK mode without doing a black ink change (I’ve heard of this happening a few times over the years, but it’s very random and I don’t know what causes it). Have you tried shutting the printer down and unplugging both the power and USB cables, taking out the carts for a few minutes, then plugging in the power cord and turning the printer back on (it should display “NO cartridge, install cartridge” message), then installing all refill carts (with either the refill or Epson MK cart), to see how the printer responds? Do you have a black ink conversion kit?

Please let me know so I can help you resolve this issue and get back to happily printing.
Best regards~ Dana


#5

Thanks, Dana. Still no luck. Here’s the latest set of attempts
a. Tried what you said above, says “set ink crtg”
b. Put all carts back in with Epson MK: correctly ID’s LLK as non-genuine, shows Epson MK as empty box (no shading) “invalid Ink Cartridge” IE, no difference from before
c. Put in Cone MK – went through screens, gets to “ready” but cuts out with same error screen as before. This didn’t work either

  1. Tried starting with Photo Black instead of Matte Black.
    a. Started up okay, recognized the PK
    b. But still get the same ‘quality/media’ error message when I try to print, even with various different media specified.
    c. In Printer Info, both types (MK and PK) still grayed out.
    d. Status monitor shows all ink levels properly with PK

Tried MM
In Maintenance mode under Cart info it only shows PK, although I have the MK installed. No way to access an NPD value to change anything.

Tried firmware update: using Epson Remote Panel and epson325691eu.UPG (Epson US website had no firmware) I reflashed the firmware. Didn’t help.

When I open the status monitor it shows T6061 (a 220ml photo black, not the 220ml Cone that was actually in the slot. The printer wouldn’t accept the Epson MK (invalid). Print attempt still brings up error message.

With fresh firmware, tried Epson MK again but still reads Invalid Cartridge.

Put in PK cart. Still get error message and MK/PK in printer info still grayed out. Status monitor is right about the PK cart, but MK/PK box still grayed out. .
Does any of this help? Another day, more attempts, and still a dead Epson. I’m burning through a lot of ink in the frequent startups. Is this printer a schizo? with dual MK/PK personalities?


#6

Another update: Being frustrated I resorted to uninstalling and reinstalling the entire set of Epson software on my computer and completely restarted the printer after a plug-out of a a few minutes. A test print actually printed! But in photo black (which is what I started the printer with). But something is still odd, since the printinfo MK/PK panel is still grayed out and unresponsive. I’m too tired to pursue it further today. But at least I got some ink on paper. I really hope I don’t have to do the conversion (again) back to matte black and waste a couple hundred clams in ink loss. Anyway, that’s the latest. Thanks! Charlie


#7

Back again. Printer has “spontaneously” (not really) reset itself to Photo Black from Matte Black after it read the MK refillable cartridge. At least it works again. I think maybe we need to take this offline.


#8

Hi Charlie~

So, the printer is in PK mode again? Do you have all media type settings (both matte and gloss), or just gloss? In your post #6, when you were able to make a test print after reinstalling the driver, did you have to do a black ink change cycle to go from PK to MK?

~Dana


#9

First, I apologize for your frustrating experience, and am dedicated to help you thru this and back to happily printing.

I wrote “spontaneously” because the printer changed it’s black ink mode on it’s own without you doing a black ink change procedure.
As I explained earlier, the 4880 (and 7880/9880) refill cartridge chips are all programmed with information for all color positions. For some reason, it seems the PK is stronger, so if the printer is in PK mode, the printer easily accepts the black cartridge, but if the printer is in MK mode, occasionally the printer will get confused and either give an error or change it’s self to PK mode.

It’s been several years since I’ve used a 4880 printer, and we no longer have one here for me to test with, but have several 7880/9880s (which were released around the same time as the 4880, and refill carts have interchangeable chips on both cartridge models) using our refillable carts with both ConeColor and Piezography inks. With our 9880 that is set up with ConeColor ink, we print on fine art papers, so use Matte Black ink, though when I check the status monitor or printer LCD panel, it shows a PK cartridge installed. In the printer driver, it lists all media type settings (both matte and gloss), so I am able to select the Enhanced Matte setting I used to make the profile I’m printing thru, and print without any problems, even though the printer clearly sees the cartridge as PK.

Are you using Mac or Windows? What operating system version? I’m curious if the error you’re getting is OS/driver related.
Have you tried reinstalling the driver as you did in post #6, then installing the Epson MK cart?

Please let me know so I can help.
Thanks and best regards~ Dana


#10

Dana - I have been using the printer in Photo Black mode for a couple of days for some BW prints and it seems to be functioning normally, more or less, in that mode. Under the color mode in the print dialog, I can see and access all the available paper types (gloss and matte and others) but under ABW I can ‘see’ all paper types (not grayed out) but can only access the photo paper types, no matte. However, the ABW mode is printing rather dark, even under the “light” setting, which might have to do with my having to substitute a kind of pseudo-matte paper choice in order to get it to print at all with the PK (all I have is matte paper - currently running the Breathing Color Vibrance Matte which is a fabulous alternative to Enhanced Matte for proofing, and even cheaper).

To answer some of your other questions, yes I do have the Epson ink swap conversion kit. I did ultimately re-flash the printer with firmware and re-install all the Epson driver software (I’m on PC, not Mac). I tried the MK cart (Epson one) after the re-installs and it still said Invalid Cartridge. It only worked with the Epson PK cart installed, then it printed.

Does any of this help? I can’t see any way around a conversion back to MK, can you? Maybe that’s the path of least resistance. Thanks for the help, Dana. C.


#11

Thanks for the additional information, this is helpful to better understand your situation.

I contacted another customer who experienced this with his 4880 a while ago, because he told me he got it to work, but didn’t explain how at the time. This is what he said: “The best I could do is just to exit out of the error message using the printer’s buttons & then the job prints. I pay no attention to the “Print failure” popup on the computer.” He was using the refillable cartridge/chip with MK ink, and printing on matte/rag papers.

Or, if this doesn’t work for you, I recommend doing a black ink change cycle, then use the Epson MK chip on your refillable cart so the printer reads pure MK and not get confused by the MK/PK mix. Follow my instructions above to attach the Epson chip to your refill cart, and make sure the chip is secured flat/flush on the cart before installing. If the above workaround doesn’t work for you, and you need to do a black ink change to get your printer back in MK mode, then I will talk with Wells in the sales department, and determine an appropriate discount to put on your account, to use on your next order.

Please let me know how it goes, if you have questions, or there’s anything else I can help you with.
Best regards~ Dana :slight_smile:


#12

I’ve had to avoid the printer for a few days out of frustration. But, I did do a proper MK/PK conversion, hoping that would get me at least back to where I started. Now, with the(Epson) MK in, the printer is bricked again, back to where I started when I first plugged in the Cone MK cartridge. Same error message, same inability to print anything, same everything. Seems to think it’s still in PK mode- status monitor still grayed out for both inks, only glossy papers accepted with ABW (other wise grayed out). I’m going to try reinstalling the driver, I guess, since I’ve tried everything I can think of to get this large paperweight going again. I guess I could do another conversion (back to PK) then try it again to get MK into the printer, but that’s getting tiresome and expensive.


#13

Update - it’s gotten worse. Now, when I try to get to the print menu I get a box saying can’t do it until I install a printer. But if I restart the computer, it will see the printer and let me access the print dialog ONCE (but without the warning screen about non-Epson ink) but then it still won’t print (goes to the second screen, that shows printers (and it does show the 4880 in that and in the devices and printers) but after that nothing happens. If I hit print again, it reverts to saying no printer installed. I resorted to a system restore for several weeks ago, but that didn’t change anything. So I think the print driver is okay (no change either now or from the restore point). The 4880’s a brick now.

I tried messing with the print spooler, but I don’t think that’s it. If I could just get the printer back to its original (out of the box) condition, maybe that would help, but I can’t figure out how to do even that. BTW, there is no way I’m going to go anywhere near this printer with the Cone MK cartridge, so any suggestions about chip swapping and whatnot are not viable for me at this point. I just want to get back to where I was before I ever tried this stuff, but that keeps getting harder, not easier.


#14

Yet another update: after more time trying anything I could think of I’m back to where I started with the error message, sort of: Now the printer seems to recognize the MK conversion, but is still schizophrenic. The driver menu still thinks it’s PK, with the PK paper selection and ABW grayed out for anything not glossy. I tried every combo of paper and quality, with no effect. The printer LCD shows MK in the slot. When I try to print, I get a few seconds in the print queue before the non-genuine message shows up, then the error message, then the job disapears from the queue. Now the error message (media type, quality) is back, preventing me from doing anything, BUT it now shows matte black with the other 7 colors instead of PK. So I seem to have swapped inks back to MK but the problem remains that the printer is confused. I haven’t tried stripping all the software again from my computer and re-installing it, and re-flashing the firmware to the printer since I still don’t know what’s causing the issue. So the fun continues.


#15

Thanks for the updates. I’m sorry to hear your frustrating experience is continuing, and for no responding sooner (I’m out of the office on Wednesdays).

It sounds like your print driver is correctly seeing the MK cartridge/chip, but there is some sort of confusion between the computer and printer. I don’t have a 4880 here to check, but know you can initialize settings on other pro model printers thru the printer’s control panel, under the Printer Setup menu. I suggest doing a refresh- shut down both the computer and printer or a few minutes, then reinstall the print driver (and if you can, initialize the printer), then make a test print.

Please let me know how the refresh goes, if you have further questions or there’s anything else I can help you with.
~Dana


#16

If you’re not going to use the refillable MK cart and ink, I will ask you to pour the ink from your cart back into the bottle, then seal the cart in a zip lock bag, and ship the cart and bottle back to us for a refund. Please let me know how things go after trying my suggestions above, and if you’d rather use the Epson MK cart, then return the refillable MK cart and ink.

Best regards~ Dana


#17

More updates - I stripped everything Epson from my PC, including the registry items, and re-installed the driver and re-flashed the printer. At first I thought I solved a few things, but then I noticed I had turned the printer into a 4800! That’s what it says in the device manager and in the page setup, and the ink status monitor isn’t working (obviously), even though the printer LCD seems to show the ink levels correctly. But I did a few ABW prints on MK and it worked okay. However, I have to shut down Photoshop every print and start it up again and re-do the setup or it says “need to install a printer…” . Well, I think I must have put in a 4800 driver or firmware (the only firmware I could find was on the Epson Europe site, no firmware on Epson USA). The driver/printer knows something is not lining up, but at least I got somewhere… now I just have to get back to having a 4880 (sob!). As far as shipping the MK back, Dana, we’ll work that out separately. BTW, how does one “initialize” the printer? I’m going to be out of town for the next week, but I can make some progress today I’ll post them.


#18

I’ve never heard of your problem of “need to install” printer or having to restart Photoshop for each print, and think it sounds driver related, so suggest totally removing/uninstalling the current driver, then downloading a fresh copy from the Epson site and doing a clean install of the 4880 print driver.

I don’t know exactly how to initialize the 4880 printer, but on the 7880/9880, you push the Menu button on the printer, select Printer Setup, then scroll + select Initialize… it may be similar on the 4880(?)

Please keep me posted, thanks~ Dana


#19

Just returned and haven’t tried to start up yet, but before I left I saw what I think exemplified the schizophrenic nature of the printer as it stands: (I did re-install the 4880 driver, several times in fact, with different versions, and the firmware too). When I open up the Page Setup screen from the initial print screen, it shows at the bottom the color bars for the inks - this says PK, not the (epson) MK that is installed. At the same time, if I go to Utilities and the Status Monitor 3, it shows the proper MK cartridge. So on the same screen, you can see the printer thinking it has both blacks. I’m still tinkering, though, with no resolution in sight. I really hate to initialize the printer, since I fear that means it will flush all the ink lines down the drain, thinking it has to fill them as a new setup. More later…


#20

How bizarre! I’m not suggesting you do an Initial Fill (charging all the lines with ink), because I don’t feel this would change/effect your results, but Initialize Settings (which I don’t even know if it’s an option with the 4880 printer, but IS with the 7880/9880), to make it throw out what it seems to remember about cartridge chips, and re-check the chips for accurate reading of the black installed.
It’s been a few years since I’ve used a 4800 or 4880 printer model, but seem to remember experiencing a mix-matched black ink reading in the print driver, and believe I went to the status monitor and selected the correct black, or did an “update”, then shut down and restarted the printing application and it was correct when I went to print again.

Please keep me posted!
Best~ Dana