Epson Service Adjustment Program for SC P7000 won't run - drivers too new?

I’ve tried it on Windows XP, on Windows &, on Windows & in XP SP3 compatibility mode, no dice. It sees the printer (it complains if it’s not connected) and the program runs but when I actually try to do anything the program crashes and closes.

I run on a Mac so I set up various Parallels Windows machines to try this but they never had the printer driver installed before, so that’s all just done using the latest downloads from Epson.

I’m wondering if the AP is expecting older drivers, and there’s a newer version of the AP to go with the newer drivers but of course nobody has that for download :frowning: It’s all V1.0.1 everywhere.

Anyone run that version of the AP on a machine with the latest drivers?


  1. Make sure that you have the printer installed, USB connected via the VMWARE connection, and the Epson driver installed, and the printer installed in Printers control panel.

Then it will work.


Oh! I had done all of that except the last part - install the printer to be usable as a printer on the system (because, of course, I never planned to.) OK thanks I’ll try that when I’m next at the printer next week and see.


Turns out installing the driver had already created/installed a local printer for it… so that wasn’t it. Epson driver installed (goes through whole “found new hardware” process afterwards and is happy and complete), connected printer via USB, tell Parallels to attach that USB device to the machine, Printers&Faxes screen shows it connected and ready.

Run the SA program and… crash. I run it on Win7, Win XP home, WinXP Pro, and while the exact crash behavior differs, none of them will run successfully.

XP Pro crashes silently. XP Home gives an “Application Error” dialog box with addresses (probably because I have Visual Studio installed on that machine) and WIn 7 says “Epris02 has stopped working”

I had bought a copy for $25 from ebay. Thinking that maybe it was bogus I bought the oft-touted $40 copy from Exact same program, exact same behavior, and I wasted the $40.


Sorry to keep talking to myself… I was trying different machine configs - for instance giving the machine the Parallels max of 4 processors and 8GB of RAM. I don’t think that actually had anything to do with it, but I did discover that if I, just as rapidly as possible, even before Windows can fully paint the screen as it’s booting, get the program fired up and click through to a command it can issue it. Just one command. Even a long-lasting one, like NVRAM Backup. All further commands fail until a reboot. All commands fail after a reboot too, if I wait around before firing up the service program or before clicking through to an action.



I have run this exact software just fine on Windows 10 and 11.

Maybe win 7 is too old.


That’s an interesting idea - because the program itself is so old, I’ve been trying older copies of Windows. Maybe I’ll see if I can find a copy of 10 to run it on. So far the “reboot-then-quickly-run-one-command” thing is working out, it’s just really annoying.


Well I’ll be danged. Installed Win10, works flawlessly.

So there’s something that needs to be shouted from the rooftops. Epson Service Adjustment Program for the Surecolor P6000/7000/8000/9000 series requires Windows 10 at a minimum.