EPSON R-3000 Cartridge LK nor recognized

printer

#1

I reported yesterday that my LK cartridge is not recognized by the printer. It is the first time I have refilled this particular cartridge. Refills on other cartridges went without flaws. I’ve cleaned the contacts on the printer with alcohol and cotton swabs, tapped the cartridge on the table to release any air bubbles and unplugged the electric on the printer overnight. When I put the old (manufacturers) cartridge back in the printer it recognizes it (and the fact that it is empty). What else can I do to get this cartridge to be recognized?


#2

Hi Tom~

Cathy told me you called the other day, and gave me a heads up that you would be posting on our forum for support.

After reviewing your rider history, I see you purchased two sets of R3000 refill carts. Are you currently using the first or second set of carts? The second set of carts was purchased about eight months ago, and if it’s been working well up till recently, I suspect you may be dealing with a dead battery on your LK refill cart chip.
You can read more about the chip batteries (and how to replace them), here: http://www.inkjetmall.com/wordpress/product-use/r3000-cartridge-batteries/
and we have replacement chips available, here: http://shopping.netsuite.com/s.nl/c.362672/sc.18/category.84880/.f

Please let me know if you have questions, your results after replacing the battery or chip, or if there’s anything else I can help you with.
Best regards~ Dana :slight_smile: