Epson Pro 7880 Nozzle Issue


#1

I’ve tried the Windex fix, multiple cleanings and this is what my nozzle check looks like. I’m looking for any suggestions that might get my 7880 cleared up.


#2

Windex contains ammonia and this can mess up a print-head.

Please look at this: Print Head Cleaning Tips and Preventative Maintenance


#3

I’ve ordered and received a Large Format Printer Cleaning Kit from you guys and performed the cleaning per your video. Unfortunately, my nozzle check is about the same. The green is 90% missing. Is there something I should try next?


#4

If still no good:

First, (if you have not done this) clean the flush box, cap station, etc. You may need to actually remove the whole unit and make sure the tube and vacuum motor are not gunked up. (this is referenced on many threads here along with ways to verify working, etc.)

See if this works.

Second, you may need to replace your dampers. They should generally be replaced every 2 yrs.

Third. You may need to manually remove the head and purge flush it (carefully) with our small format kit head adapter. This is not a workflow we always recommend. It’s a “last chance” type of thing if you suspect the head is finally dead. When doing this, never get any fluid on the exposed ribbon cable port.

The first two should be done before the last.

best,
Walker