Epson Pro 3880 mainboard

hello, the epson 3800 mainboard is fine on the 3880. are they the same? thanks sergio

they aren’t the same as they require differ M and LM chip encodings.


thanks, then they gave me a 3800 mainboard, maybe that’s why when i connect it (the 3880) to the pc it does not install the drivers and i get the 3800 icon

yeah, it’s a 3800 now essentially. It may work with the old 3800 LM/M chips and control chips however. Not entirely sure as the head voltage is different . . .


capito. grazie :ok_hand:

Good evening, on my epson 3880 I replaced the ink black selector for leaks. Operation apparently ok. Then I replaced the mainboard because it no longer printed. By mistake of the seller, I mounted a 3800 mainboard, I was able to do the cleaning cycles and try the selector, only that the pc did not recognize the printer to install the drivers and therefore I could not use the Adjustment program.
Then I reassembled his mainboard and the pc recognizes it, I can use the service program but it gives me error 1501 and everything remains stopped. I tried to do some resets with the program, but the error does not go away. Can you help me solve it. Thank you
sergio IMG_20200301_172930 IMG_20200301_173049 IMG_20200301_173113 IMG_20200301_173210

From Field Repair Guide:
Screen Shot 2020-03-01 at 10.20.11 AM
From Service Manual:
Screen Shot 2020-03-01 at 10.20.37 AM
You can download the manuals here if you don’t have them.

See pages 213-215 in the Field Repair Guide, and page 129 of the Service Manual, for pictures of the parts in question. They are located on the left side of the printer, above and to the left of the paper feed motor.

I think this is part of the paper feed system, but I’m not sure. Since you have been switching main boards back and forth, your problem may be due to an electrical connection rather than the part itself. Or maybe the sensor is obstructed by something not put back together quite right. I’m just guessing.

Good luck,

Thanks, I opened the mainboard and disconnected and reconnected some contacts, following the service.
I turned it on again and the 1501 went away, but the 1410 came out. When I turn on the pump it starts to load then it times out and the error 1410 arrives. Maybe the time has come to throw the printer in the landfill. But I’m stubborn and I want to try with your help to bring her back to life. Thank you

Did you cycle off/on again after the 1410 error appeared?
Do you still have the 3800 main board installed?
Try the original main board again?
(Just thinking out loud.)

Screen Shot 2020-03-01 at 1.36.48 PM

thanks, tried, right card, maybe KO, sergio :weary:

ciao a tutti, epson 3880, si possono azzerare le stampe totali. sto per acquistare una 3880 usata e il venditore mi dice che ha stampato 20 fogli. :innocent: