Epson P800 Decoder Board Install Error - Cannot Recognize "Cyan" Cartridge

Hi there,

I attempted to install the decoder board to prepare my Epson p800 for ConeColor Pro ink, but I ran into an issue. Here are the steps I took:

  1. Ensured that automatic firmware updates are disabled for the printer.
  2. Installed the decoder board per video instructions (YouTube).
  3. Turned on my Epson p800.
  4. Saw an error–my printer cannot recognize “Cyan” cartridge and ONLY that cartridge. Please see the uploaded image below for my error.

My attempts at debugging, but nothing has worked so far:

  1. I opened the ink tray cover, and removed all the OEM cartridges and re-seated them.
  2. I turned off my printer, removed the power supply, and turned it back on.
  3. I cradled the “cyan” OEM cartridge like a baby and sang it a song, hoping that my printer would change its mind.

I’m excited to see how these ConeColor PRO color pigment inks turn out, once we remedy this issue.

Please let me know if you require more information. Thank you very much for your help!

All the best,
Nick

IMG_1716

Sorry, I should’ve included in my original post that I purchased this Epson p800 in North America, from online retailer: https://www.bhphotovideo.com. So, I’m quite certain that the printer is from North America, but if there’s anyway you can recommend me to verify this, I’m happy to do so.

Dear @zoocrew185 we are going to send you a replacement board and we’ll need the other one back for testing. This is a new error that I have not seen before. All other errors have been related to the ribbon cables not being inserted properly but this would not be the case if a single channel was not recognized. Hold tight, email incoming.

best,
Walker

G’day @walkerblackwell ,

Thank you for getting back to me.

I did gently graze the tip of one of the cables (I think c76) during install with my finger, but I’m glad to hear that might not be the issue. I followed up separately with Wells about getting a replacement board.

Cheers

@walkerblackwell the new decoder board worked! Thank you very much for your help. I sent your team back the one which had the “Empty Cyan Cartridge” Error.

Cheers,
Nick

1 Like