Epson 9890 paired missing channels

I’ve been looking over old posts about this and have tried a few remedies, but think it’s time to dive in and ask for advice.

I’ve been working on an Epson 9890 that’s been sitting idle for a year or so after the drive belt snapped. I replaced the belt, revved it up, installed some new-ish ink (2018 exp), did an INIL FILL, dropped some piezo flush fluid on the cleaning station and pad and let it sit overnight and most channels are printing well, but the C and VM are completely missing. I ran a pair cleaning and it looked like ink was being sucked through the tubes to the maintenance tank (new tank installed before cleaning cycle is now stained black) but still no presence of C and VM on the nozzle check.

Is my head somehow dead or is it a damper/cleaning station issue? Something electrical? It seems like it might not be the head due to the pair being missing. I have a broken 9900 that I’m using for parts (delaminating head) so I can possibly swap whatever is analogous.

Thanks for any info!

Yep. Delaminated head. This is the most common channel pair because it’s right on the left edge.


Bummer! Thanks for the info, Walker. I think for fun I’m going to try putting the electronic guts of the 9890 into the 9900 (green is dying and orange is starting to die) and see if I can get it to think it’s a 9890.