Epson 9880 Clogged Nozzles - Piezoflush helped, but still not quite there


#1

I have an Epson 9880 that developed a couple of stubborn clogged nozzles mostly in the photo black, cyan and Magenta channels. Over time a few more nozzles joined the party, the prints still looked good but the nozzles couldn’t be cleared. The final demise was when a photo black and cyan cartridge (both OEM) ran dry prematurely. After this, I pretty much lost those two channels. I tried many nozzle checks and power cleans and even an SS cleaning but it showed no signs of improvement. It also would not run a nozzle check for the colors on the left side of the machine.

I purchased some Piezoflush and refillable cartridges, cleaned the capping station and flushing box as well as the wiper and ran a couple of power cleanings to get it into the system. I also cleaned the bottom of the printhead with a paper towel coated in Piezoflush. After letting it sit for 48 hours it showed a little improvement. I ran another power cleaning and a couple of nozzle tests and let it sit again. After about a week it showed significant improvement, but not perfect. The machine would also still not do a nozzle check for the other 4 colors. So I ran another power cleaning, this time however it wiped out the center section of the photo black and magenta channels.

I have run a few prints as well as more nozzle checks with no change. I am not sure what the next step should be now. Each cartridge is about half full of Piezoflush so I can probably run another cleaning, but did not know if there was something else I should look at before continuing. Any advice would be much appreciated.

Thanks!

The first image is where I started, second is after a week of soaking, cleaning and test prints, and the third is where I am at now.


#2

First thing to do.

  • Turn auto nozzle check OFF on your control panel of the printer.

  • Then do a normal nozzle check.

  • This will show you the actual nozzles that are out.

  • Post that.

Doing SSCL cleanings can damage the head so there is a chance that it is a half-damaged half-clogged head and the PF is doing all it’s able to do. But we need to see the actual nozzle check, not the auto-clean patterns.

-Walker


#3

Thank you for your response! The auto nozzle check was already off, but the auto nozzle cleaning was on, I turned it off and got the following. Is this what you were referring to?


This is looking much worse than I thought! Thanks again for your help!


#4

Yikes. That looks like post-sscl burned nozzles to me.

The only thing doable at this point is to take the head out and VERY carefully flush through the inlet spikes, through the ink manifold, and out the nozzles with the small format flush kit. The reason why I say very carefully is that you don’t want any liquid to get on the wiring that is near the inlets. This is a last ditch maneuver.

-W


#5

Walker, I injected Piezoflush directly into the head with a syringe and some tubing but it did not seem to make any difference. I pulled the head and let the base of it soak in Piezoflush for 45 minutes then flushed it some more. This removed a lot of junk and cleared up a couple of nozzles in the cyan channel. However, I lost more nozzles in other channels in the process. I am guessing that some of the crud is just moving around?

I have seen some videos of people “waterfalling” their heads by injecting cleaner through them. I do not know if I used enough pressure, but none of the channels would “waterfall”, the Piezoflush would just bubble out the sides of the head. Do you think this is just because the head is really plugged, or is this a sign that the head is just toast?

Thanks!


#6

I think what has happened is your head has become de-laminated around the edges of the base plate where the nozzles eject ink. :frowning:
-Walker


#7

Thank you again for your continued help! I replaced the head and dampers and put the oem ink cartridges back in the machine. All of the cartridges register fine except for the photo black. I get an error stating that it is an ‘invalid cartridge’. (This cartridge was in the machine before installing the Piezoflush.) I tried another new cartridge and got the same result. So I reset the chip on a spent oem cartridge and got an error stating that it was a ‘non-genuine cartridge’, this one however at least allows me to accept and use the cartridge.

I have powered down the machine and unplugged it for 24 hours in hopes that it would reset itself, but no such luck. Any ideas on how to get the printer to recognize the cartridge as valid?

Thanks!


#8

You may be forced to use it in the non-oem state for a while . . . doing multiple resets of chips (specifically if they are under 15%) can do this regardless of if the chip is OEM or NON-OEM. Epson “updated” their firmware on this printer and adde" that “nice” little feature. :wink:

best,
W


#9

I read somewhere on this forum about hitting the pause button a few times when receiving this error so I went to town on the button. After a few pushes it accepted the cartridge! Hooray! We are now back up and running!

Thank you, thank you so very much for your help and willingness to share your knowledge!

Greg