Epson 7900 will not recognize all cartridges

9890
7900
9900
7890

#1

I recently purchased a set of refillable cartridges for my 7900. Initially the printer wouldn’t recognize the MB, G, and LLB. after repeated tries it recognized the MB but still will not recognize the green or light light black.


#2

Hi Robert~

I’m sorry to hear you’re having troubles with your printer recognizing all the newly installed refillable carts. When you posted, I was in the midst of testing and troubleshooting this issue, so wanted more information before responding. After much testing, we have discovered there is an occasional issue that effects some of these carts from our more recent batch that seem to have a physical fit issue, which is causing recognition errors like you are experiencing. I have found the issue is sometimes resolved by slightly raising the chip by adding more double sided tape underneath, but it’s important that the chip be flat/flush, and if raised or slanted, could catch on the printer’s thin wire chip sensors, and damage the sensor (which we certainly don’t want to experience).
We are in the process of testing a new cartridge design, that we are told is a better match to the OEM cart, and are hopeful this will be a good solution moving forward. Until we have thoroughly tested these new carts, I can either send you replacement carts of the same design you have (but can’t be sure they’ll resolve your issue), issue a refund for the non-working carts, or if you have other carts to use in these positions, I would be happy to send you replacement carts of the new design (provided everything continues working well with them- so far, they are working better than any other x900 cart I’ve tested per the years).

Please let me know what you would like me to do to help. Again, I apologize you’re experiencing problems with your new carts.
Best regards~ Dana


#3

Thanks,

I tried adjusting the chips without success. I had bought these with the peizo flush, so I have other cartridges I can use with ink. Please send me the nrew cartridges when you have tested them.

Robert Conchie

[QUOTE=Dana-IJM;3155]Hi Robert~

I’m sorry to hear you’re having troubles with your printer recognizing all the newly installed refillable carts. When you posted, I was in the midst of testing and troubleshooting this issue, so wanted more information before responding. After much testing, we have discovered there is an occasional issue that effects some of these carts from our more recent batch that seem to have a physical fit issue, which is causing recognition errors like you are experiencing. I have found the issue is sometimes resolved by slightly raising the chip by adding more double sided tape underneath, but it’s important that the chip be flat/flush, and if raised or slanted, could catch on the printer’s thin wire chip sensors, and damage the sensor (which we certainly don’t want to experience).
We are in the process of testing a new cartridge design, that we are told is a better match to the OEM cart, and are hopeful this will be a good solution moving forward. Until we have thoroughly tested these new carts, I can either send you replacement carts of the same design you have (but can’t be sure they’ll resolve your issue), issue a refund for the non-working carts, or if you have other carts to use in these positions, I would be happy to send you replacement carts of the new design (provided everything continues working well with them- so far, they are working better than any other x900 cart I’ve tested per the years).

Please let me know what you would like me to do to help. Again, I apologize you’re experiencing problems with your new carts.
Best regards~ Dana[/QUOTE]