Epson 7800 problem - please help with ideas of how to fix this


#1

Getting an old 7800 up and going again.
This is a colour print all 8 colours are refillable carts.
After 2 years not using , I got the printer out of storage and unblocked the print head and got the printer functioning and printing out with no problems and on errors.
After 4 months of working without fault.
Yesterday half way through a print the printer seems to have fired all the jets for all the colours at the same time at the paper for 2 passes and then returned to printing the image for two passes with some gaps like a some colours were blocked, then to the end of the print like the first error all jet on to the point of were ink is running down the paper.

Done so far.
Remove print head and cleaned.
Returned print head to printed.

Run print head check paten and got same result all jets firing across the head movement path.

Checked ribbon connectors at the head , all ok.

Run print head check paten and got same result all jets firing across the head movement path.

Replace mother board of printer .
updated firmware to board.

Run print head check paten and got same result all jets firing across the head movement path.

Has anyone had this problem before or have an idea of what I can do to return this printer to the error free printer I have had for the last 4 months.

image of failed print can be found here:
https://drive.google.com/open?id=0BxCRmWcmfjKleG1WYnZnQlRVUFU

Image of print out of check paten found here:
https://drive.google.com/open?id=0BxCRmWcmfjKlZ0ZPTl9ocGFZWjA


#2

You either have a fried head control board or fried head or both. Not the motherboard but head control board.

best,
Walker


#3

Ok thank you for you comment.
I have another head on hand and just ordered a cr board and new cables to go between the two.
Should I wait till the new parts arrive 16 days or would it be safe to swap out the heads ?