Epson 7800 only printing Yellow after rebuild

Hey All-

After printing a grey tone image on museum board, my 7800 failed to produce decent nozzle checks. After several power cleanings and wasted ink, I decided to replace my 3-year-old made in China pump/capping station along with new dampers. Also pulled the head, letting it soak in PiezoFlush while sucking and push some through it. Primed the dampers and put it all back together. After a couple of CL2 cleanings, it would only print yellow. Tried a full initialization, same result but it went through all the ink. The flushing box shows mostly yellow but the capping station is black/blue/yellow mixed with no red. The wiper has a thin layer of black

It’s probably time to replace this old friend. You guys have any ideas?

Thank you!

Light Light Black has also come back

It seems to me like more of an ink pressure issue or the capping station is screwed in too tight. If the vacuum can suck ink but the head can’t print that is generally an issue with the dampers being too tight.


THAYER013 Thanks, Walker-
I unscrewed all the feed tube nuts and replaced both the washers and vinyl nuts from the feed tubes to the dampers, hand tightened then a little more when joint leaked ink. Exactly the same result. Printing only Yellow and Light Light Black with just a few lines in the other colors.

Curiously, the pattern is relatively the same in each test. Could it be the head? No black (HD Photo) at all
Also curiously, both the outside inks, LLK left and Y right, are the only one working.

No idea how to adjust the Capping Station. I replaced the entire Pump Cap Assy and the Cap was already attached. There is nothing in the service manual about it