Epson 4900 Ink Charge Not Working

4900

#1

I picked up a second 4900 on e-bay mostly for parts, but it appears to be fairly functional and when I do a nozzle check all but a couple of channels print. a few of them have some missing nozzles, but they may just need cleaned. So I loaded up my piezo-flush cartridges and tried to do a ink charge to run the fluid through the lines and head using the SP. It completed the operation but no ink or fluid was actually run through the lines. The maintenance box had nothing in it. I tried a second time with the same results. So I am assuming that I have a bad pump or something. I am not really familiar with how the ink charge works. I believe that the ink is actually sucked up through the head, but I really don’t know. Can someone enlighten me on what the problem might be and where to start looking? Thanks!!


#2

I’m slowly diving into un-replied-to posts that were buried by our previous forum software years ago.

Three things (this has been covered elsewhere on the forum as well).

  1. It’s important to prime these cartridges and to also make sure the vent plugs are out before you insert them into the printer.
  2. It’s very easy for this printer to have air-locked dampers and bad vacuum pump (cleaning assembly). These two things should be replaced regularly on the printer (every 2 years) so if it’s an internet buy one should preemptively replace these parts.
  3. It’s not always a problem with clogs. it could be print-head delamination which is a fatal head damage that is common on this printer model.

Hope this helps anyone who comes upon the thread.

best,
Walker