Epson 4880 Unlock Print Head Message

Hello. When I turn on my Epson 4880 I get a message saying Unlock Print Head. Also the Pause, Ink, and Paper lights flash. The green tap on the left of the print head is pulled out as it has always been. This happened right after I changed the ink dampers. The head does move out freely when I manually release it. But when I turn on the printer I get that message.

Also I just installed a new set of reset carts filled with PiezoFlush. I am going to flush the lines and use Cone Color ink. Could I have done something wrong? I have replaced dampers before. Any help is greatly appreciated.

Joe Kohler

I may know what happened. I also replaced the ground plate (the thin steel that screws behind the circuit board to disperse any static charge). If it was bent it may be preventing the head from moving. I check it tomorrow.

Joe Kohler

Still not working. Any suggestions what this message means? The head is unlocked.

I think you should reach out to the Epson Wide Format forum at


Hi Walker.

Thanks for the reply. I noticed a small nick on the ribbon cable. I tried patching it with a spot of liquid electrical tape, but I still get the Unlock Print Head message. So there must be a short somewhere. I’ll call an Epson service centers for advice. Hopefully it’s just the cable that needs replacement.

I’ll do the replacement myself. I found some generic cables online. And there’s an excellent video on YouTube showing exactly how to replace the cables. If anyone’s interested here’s the link. Replace Epson 4880 Ribbon Cables

Joe Kohler