Epson 4880 One Ink cartridge will not hold a prime so it won't print

4880
4000
4800

#1

Installed set of inks in Dec 2014 time frame with no issues and have been printing just fine. After taking each cartridge out and gently rocking it back and forth, the one position (light magenta #5 shade) will not print. Tried repriming it but still not good. It appears to me that the cart won’t hold a prime as it keeps an air pocket at the nozzle end even after pulling a fair amount of ink out through it.

I filled that slot with piezo flush cartridge and it works fine. That will print red fine.

This makes me believe that I have a bad cartridge.

Is there any suggestions or anything else I can try?


#2

It’s a bit unusual that the cartridge was working fine until you took it out to agitate the carts. But, I agree that is sounds like a faulty cartridge valve that won’t hold a prime, so I will get you a replacement in the mail tomorrow. You should see it before the end of the week. Let us know how it turns out.

Kindly, Kelly