Epson 3880 suddenly started cranking out blank pages


#1

I am an amateur using the Epson 3880 with Mac OS X Yosemite 10.10.3 and Lightroom 6.01. I have had it for 2 1/2 years and printed about 500 pages, mostly 17x22. Never had a problem, except for an occasional nozzle cleaning. Over the past six months, I have replaced OEM cartridges with Cone refillable cartridges and ink, replacing the chipset as recommended, and it had been working beautifully.

My Epson 3880 suddenly started printing blank pages. When I try to print, the 3880 goes through all the motions: moving the print head back and forth, advancing the paper etc. Except what comes out is blank.

I did various things like re-installing the driver without luck. I then worked through the printer menu. Nozzle check keeps on printing blank. I did Power Clean 3-4 times. Tried Nozzle check again, both with Print and Auto. I had just replace the Maintenance cartridge for the first time a few months ago. Now after all the power cleans, that is full too. I contacted Epson support. They told me that if the power clean did not work, I would need to take it a service shop:

“We will know for certain if the print head is clogged if you are able to run a nozzle check from the control panel of the printer. Menu>Test Print>Nozzle Check>Print. If the nozzle check pattern does not print, we have confirmed that it is either a print head or other hardware problem. In that case, you would need to take the printer (or ship it) to a service center”

At this point I am out of ideas and my guess is that it is not worth the effort to try to lug this to a service center considering how expensive repairs are, relative to a new printer that comes with a set of ink cartridges. Would be a shame though considering that I just finished installing the Cone cartridges.

Any suggestions would be most helpful.
Thank you.

cortlander


#2

Hi Cortlander~

That sounds very frustrating.

Please open the cartridge bay and remove your cartridges to check the physical ink level, to check if they contain ink or are empty.
Did you prime the refill carts before installing into your printer?

Please let me know, thanks~ Dana


#3

Dana, yes I did prime the refill carts, and the prints had been coming out beautifully. I printed one, came out nice, and the next one was a blank, and nothing more after that. And yes, the cartridges are at least half full, some had been refilled a couple of months ago, and I also shook them before inserting back. I had been working them in replacing the OEM’s over the past 6 months and had been very happy with the refill carts and the printer. The 3880 has been lightly used, since I do this for fun, and it would be shame to throw away something that still looks new.

I am also curious if these will work with the new P800 if I am forced to junk the current printer.

Thanks,

cortlander
www.photoshah.com


#4

The fact that everything dropped out at once is disturbing…I would be worried that the ribbon cable has failed.
Try this to verify that you’re getting ink through the head: Fold some tissue paper and stuff it into the maintenance tank. Run a cleaning cycle and check the tank. If the tissue is soaked, ink is flowing through the head and something else is wrong.

About the P800: Since the inks are different colors (according to Epson), the carts will have different chips. It [i]may[i] be possible to put the P800 chips under the refill chips and have them work, but I doubt it. I believe that new chips will have to be developed, but hopefully we can use the same physical cartridge.


#5

Hi tjncooke,

After running the power cycles, my relatively recent maintenance cartridge became full, and upon checking it, there was plenty of fluid in there. Replace maintenance cartridge message also came up. So I guess ink is flowing through the head?

You are right, this looks bad.

Thanks,


#6

Hi tjncooke,

After running the power cycles, my relatively recent maintenance cartridge became full, and upon checking it, there was plenty of fluid in there. Replace maintenance cartridge message also came up. So I guess ink is flowing through the head?

You are right, this looks bad.

Thanks,

cortlander


#7

Try running a regular cleaning cycle and listen carefully to the printer. Ignore the whirring and head movement noises and listen for high pitched, low volume sounds. It should sound like eeeee-eeeee-eeeee-eeeee with a beat between them at about 2Hz. If you go through an entire cleaning cycle without hearing that, I would be willing to bet money that the head is no longer receiving signals. The capping station can pull ink through, but no nozzles fire.

If you’re handy, give the service manual a look and maybe it’s as simple as the cable came loose…


#8

Thank you, tjncooke. Great suggestions. I will try them out. Yes, I am reasonably handy, (an Electrical Engineer) and tinkering around with the printer is an excellent idea.
I have a user guide, but not a service manual. I took a quick look via google but could not find one. Any ideas who may have it?


#9

http://www.2manuals.com/product_info.php?manufacturers_id=&products_id=1361


#10

Thank you so much, Jeff.


#11

Thanks for your input tjncooke, I agree it sounds like electrical failure since it’s effecting all channels, and ink is flowing thru the head and into the maintenance tank when you do cleaning cycles.
Best of luck resolving your printer issue cortllander, and if you are successful, please give us an update on what you did and discovered.

Best regards~ Dana


#12

Thanks, Dana. Everything you guys said made sense. I bought the service manual online. I could not try the “eeee” test as tjncooke suggested as the maintenance cartridge error would not let me get to a cleaning cycle. So I opened the printer to see if anything seemed strange - not that I am an expert on this. The trouble shooting steps in the service manual took me to the Print Head or the Board Main Assembly. Opening just the cover of the Print Head assembly, I see the bunch of ribbon connectors, but who knows what is not working between the Main Board, the gazillion ribbons and wires and the Print Head. I would guess that getting either the Board or the Print Head replaced would not be worth the expense.

So there it is…a temporary end to my brief photo printing passion


#13

Sorry for not having the magic/easy answer, but yes, it sounds like this is going to require more investigation and taking the printer apart…


#14

Probably just a really stupid suggestion, but…
Is your printer Q empty? I had a similar issue with my R3000. I’d go to print and I’d get blank pages. Turned out the printer Q wasn’t empty. Once I deleted the unprinted files in the Q, everything worked fine. I’m on Windows printing with QTR.
Good luck,
John


#15

Good thought, but they’re using Mac, have reinstalled the driver, and even the nozzle check from the printer itself is blank. :frowning:


#16

Thank you folks, I deeply appreciate all your help.
Am I correct in expecting this to be an expensive repair job, even if I considered it?

Best,


#17

There can be a lot of troubleshooting involved in finding the cause of the problem, then depending on the problem, may be a hassle or expensive to fix- BUT, it may be as simple as a loose ribbon cable. Unfortunately, you won’t know the cause of your problem until you take apart the printer and do some investigating. OR, you can bring it to a repair center, but they’ll need to do investigating too, which you’ll be paying for, on top of any parts they determine need to be replaced.

If you end up getting it fixed, please let me know what the problem was, I’m curious.

Best~ Dana


#18

Thank you, Dana. Your advice has been very helpful. I did open the printer up, but did not find anything obvious. Now I am thinking about the next step. Even taking it to a repair center is a couple of hours of time, plus the effort to carry it. I see machines in need of repairs on Ebay are listed for about $300. Maybe I could get rid of this one and get the new P800 when it is available.

In case you are curious, this is how it looked after I opened it up. (Yes, I was able to put it back again).