Epson 3880 maintenance cartridge


#1

Hallo all
I am in the process of installing the new Pro inks. The printer asked for a new maintenance cartridge, which I duly installed. I used a new original Epson part. The printer reports: “No maintenance cart. Install the maintenance cart”, which I’ve done several times. Also tried a second new cart, with same result. Cleaned contacts with alcohol - no whiskey added. Printer only gets whiskey when it’s working.
Does anyone have an idea how to solve this?
Many thanks in advance.


#2

Your refillable ink carts are causing the maintenance cart to not be recognized… happened many times on my 2 3800’s… replace your ink carts with Epson original carts one at a time and see when the maintenance problem goes away… it can be a nightmare of chasing your tail… very frustrating


#3

Interesting. My 3880/K7 setup worked normally in that regard for a while, but at some point stopped reading the level in the maintenance tank, though it still works. I just have to check that it doesn’t get overloaded once in a while.

The Epson Printer Utility Status Monitor shows all of the ink carts as genuine with production dates of 10/05 or 09/11. The maintenance cart section is grayed out.

Do you have a chip resetter for the maintenance tank?


#4

Thanks very much for your help.


#5

Thanks for your help.