Coupon Code not Working

r3000

#1

I really don’t know where to post this. I just tried to use the coupon code for the 15% discount (the one advertised on this forum) to buy a complete set of carts w/syringes for the R3000. The reply from the web checkout page said that the code was invalid. Has the promotion expired? I decided not to place my order until I find out.

 Dustin

#2

Now, it has disappeared. I was hoping to use it too. Oh well, back to full price.


#3

And now it’s back again, after I paid full price.


#4

I just tried the coupon code again. But, it is still not working. Am I doing something wrong? I applied the code on the check-out page, the same one that asks for zip code, to calculate shipping. I am wanting to make a purchase. But, I am waiting to find out what the deal is.


#5

The coupon code is active, and only works with full sets of ink and/or cartridges. Please contact us if you continue having problems with this.


#6

Yes, I have been trying to get the R3000 cartridge set with syringes (SKU#: RCS-R3000-KIT). But, your website keeps telling me that the coupon code is invalid.


#7

No answer to my last post. I’d like to use this coupon code, before it expires.


#8

You will need to contact Sales, I do any more about coupon codes thru tech support. I had alerted sales of your issue after reading your first post, so they checked the code and made sure it’s working (and it is).
Please write to sales@inkjetmall.com, and either Jon or Wells can help process your order with the coupon.

Thanks~ Dana :slight_smile: