Color chips are not working with Epson 3880


#1

Hi. My color chips are not working with Epson 3880. I have photo and matt black working fine but none of others works. Do I have a bad set of chips? I did not use those cartridges for some time after I bought them. I only used blacks. I wanted to use them now and none are working.

what should I do next???


#2

Hello-Often times one faulty or ill fitting chip/cartridge will cause recognition issues with the 3800/3880. Try the following to determine which chip is the culprit OR if it’s a simple fit issue with the cartridge in the printer itself:

1.You will need to make a piece to trick the ink cover switch into believing it’s closed, you can use a folded up piece of paper for this, you may have to triple fold it to be the exact thickness needed. With the ink cover OPEN figure install the piece of folded paper so you get a read on the chips with the cover open (this gives you direct access to the cartridges)
2.Once you get the cover sensor tricked into believing it’s closed go ahead and push each cartridge in one by one to see if you can get them to read
3.You can also push cartridges up & down and left to right
4.If you find you get recognized cartridge(s) by doing this, you can apply a piece of masking tape to the top or bottom or side of cartridge, depending on which way you move the cart to get the recognition. Sometimes I have found that when pushing the cartridge IN and get a recognition, that I can apply a small piece of tape the top of the cart where it is held into the printer
5.You may find 1 cartridge with a slightly bad fit or multiples, although multiples is rarely the case. This will take some detective work on your part so be patient
6.If none of these solutions work, then you have narrowed it down to which cartridge has an actual bad chip and I will send you a replacement

It is more often that one cartridge has an ill fit in the printer causing recognition issues rather then a faulty chip, although it is possible.
Let me know you results-Kindly, Kelly


#3

I actually tested those cartridges one by one and none worked (other than 2 blacks on left…).


#4

This is very odd behavior, leading me to think there may be a concern with the chip connections, try this:

The plastic base of every 3880 reset chip should have three small plastic tabs around the side that hold it onto the cartridge. If any of these tabs are broken or bent inward, the chip will not stay secured to the cartridge, therefore not have a good connection with the Epson chip underneath, which will cause an error. Also, on the back of every reset chip, there should be three metal pins that stick out and touch the Epson chip- the three pins should be equal length for proper contact with the Epson chip. Please check the plastic base to make sure there are three plastic tabs, and if they are all in place, gently bend them outward slightly to ensure they catch and hold onto the cartridge. Also check to make sure the three metal pins are present and equal length. On the front of the chips, please check the gold contacts to make sure nothing is on the contacts that would interfere with the printer’s ability to read it- if you see anything on the gold contacts, gently clean them with either an alcohol pad or pencil eraser. After checking all these things, push the reset chips back onto their corresponding cartridges and make sure they are pushed all the way onto the cart for a good connection with the Epson chip, then reinsert the cartridges into your printer and see how the printer responds.


#5

I just purchased a new set of refill carts for my Epson 3800. I also ran a complete flush after cleaning out the old cart and filling them with the cleaning flush all print heads seemed to be cleaned and printing out when I tested it on a blank sheet of paper. It showed the slightly red or magenta color of the flush solution on it. I filled the new carts with in and placed the OEM chips in place as directed. When I installed them they all show up but I get an error message showing the yellow cart is not being seen and told to install the cart. All the other ones show to be full and ready to perform but this one keeps me from printing. I followed the above treatment to try to solve the problem but it still doesn’t show up. I removed all the carts and then plugged them back in again with the same results. Error actually says No Ink Cart but it shows the yellow to be flashing and needing to be installed. Can you give me any ideas on how to get this up and running soon. I bought the new carts a few weeks back and installed them last week but haven’t had time to deal with this until today. Thanks a bunch, Charles


#6

Hi Charles~

Occasionally one cart can not have a tight connection between the chip and printer’s chip sensor, which can cause all carts to read “no cart”.

Please unlock all 9 carts, then push them all back in snugly, while watching the printer’s LCD panel. When the LCD says “cartridge door open, close door” is when it sees all the cartridge chips, and it’s ok to close the door (but, if it says “no cart” or a similar message, then it’s not time to close the door). On a rare occurrence, when one cartridge chip doesn’t have a tight connection with the chip sensor, adding a thin wedge of paper under the cart makes a good connection for consistent/good read. To do this, take a piece of regular typing paper, about 3x4", and fold it in 1/2 twice so you have a 3x1" folded strip. tape the paper wedge to the bottom of the cart, and insert the cartridge into the printer so it locks into place.

Please let me know your results or if you have any questions.

Thanks~ Dana