Chip Resetter does nothing

printer

#1

I recently purchased a set of refillable cartridges for my Epson 7890 and a chip resetter to go with them. The cartridges work fine, the chips are working but when I put the resetter on them nothing happens. The light doesn’t come on. The levels don’t reset. Nothing.
Anyone have any suggestions as to what may be the problem?


#2

Hi Jesse~

Are you holding the resetter to the top of the cartridge so the front and side guides are tight to the cartridge for a good connection with the cartridge chip?
If so, you can try resetting the resetter by following the instructions below.

[U][B]Reset the Chip Resetter:[/B][/U]
Occasionally, chip resetters need to be reset just like any computer does. To reset your resetter, please open it by unscrewing the two screws then inside you will find a board with three round batteries attached (batteries are on the same side of the board as pins that touch the chip contacts). Gently pry up one tab holding each battery down and slide the three batteries out of place. Wait 30 seconds then slide them securely back into place (it doesn’t matter which battery goes into which spot, they’re all the same) and put the resetter back together. Test the resetter on a different cartridge chip (sometimes a faulty chip can short out the resetter, so testing on a different cart chip rules out the chip).

Please let me know if you have questions, your results, or if there’s anything else I can help you with.
Best regards~ Dana :slight_smile:


#3

Okay, I tried resetting it 3 times, each time tried a different cartridge, still no luck.


#4

Thanks for trying and reporting. I’m sorry to hear it’s still not working, and will send a replacement.

Best regards~ Dana :slight_smile: