Chip not working on new cart on 4800


#1

I am a newbie trying to get started here. I bought a used pro 4800 that came with near empty epson cartridges, that had been sitting “6 months”, and have purchased the new carts and filled them with piezoflush. Unfortunately I threw out the old epson carts when I put in the new Inkjetmall carts. I am trying to get to complete an initial fill cycle, but yellow cart is giving lots of grief. This is what has happened so far:

  1. filled carts with fush and secured chips. Inserted carts. Followed directions for initial ink charge.
  2. Following directions got me to “Self Testing2”, not “maintainance mode 3” like it was supposed to do. So tried the following:
  3. Turning on and off, discovered it was showing yellow cart problems. Chip was missing (I know know it fell inside printer, as it happened again with new chip) . Ordered 2 new yellow chips, and installed after it arrived.
  4. New chip didn’t read. Other carts and maintenance talk (cleaned and reset with chip setter) all show solid black boxes, which is good. Yellow cart shows empty box with diagonal line through it on control panel.
  5. Tried chip resetter, which turned solid green but then seemed to burn out completely. It is dead. Used spare chip, but printer ate it. It was gone when I pulled it out. So put replacement chip back.

Reading relevant threads here, I have tried cardboard wedges under the carts to help assure firm contact between chip and pins. This saved the cyan cart, which was on again off again reading. But it is not working on yellow cart. I have checked the pins inside and as best as I can see, they don’t appear bent.

So what next? Order new chips and a new chip reader? I’m not confident the reader I received with the kit is the right one for the 4800 (looks different than image on your site) although it seemed to work on the maint tank before it burned out. I’ve spent close to a grand on this experiment so far, and am trying not to be discouraged. Kicking myself for throwing out epson carts- newbie mistake! Any guidance for moving forward much appreciated!


#2

A couple of suggestions: If the chip resetter dies, open it up and remove the batteries and then put them back in. I have a 7800 and have had problems with the cartridges not be recognized. Short of replacing the contacts inside the ink bay, I have used contact cleaner on the chip. I have found that putting shims on left side the cartridge, the side opposite the chip helps force the chip against the contacts in the ink bay. For the shims I have used name labels that you asked to fill out and put on your lapel at conferences. I cut them in half lengthwise and put one on at a time until I get a snug fit and hopefully the that diagonal line is gone and the cartridge registers full. Good luck.


#3

'm happy to report that I have had success in getting the first initial fill to complete! It feels like a huge victory. A number of your tips were extremely helpful, so thank you!

  1. I tried to reset the yellow cart chip with the chip resetter. The light came back on (like you said it would) but did not turn green after many attempts. So I took a screwdriver to the bottom of the printer and managed to dig around with a thin bamboo skewer until I dislodged the 2 chips that had fallen in. Hurray! I was able to replace chip and insert into printer.
  2. I tried everything to shimmy cart in, but it wouldn’t work. I reset the chip until it turned green and tried inserting cart again. I discovered it would work as long as I held the cart in, gently but forcefully, while I pressed the lever down. when I got success with this, I then tried two layers of cardboard until it registered. Yellow cart successfully engaged!
  3. Suddenly cyan and magenta chips where doing what the yellow one had, so I shimmied them until they engaged.
  4. I followed the directions here for the initial fill, but they were not working for me. Instead of “maintenance mode 3” I got “self testing 2”. So I did a google search and found these instructions at
    How to Perform an Initial Fill on an Epson Stylus Pro Printer - InkOwl, which I found to be accurate:

Turn the printer off.
Hold down the PAUSE, RIGHT, DOWN buttons while turning the printer back on to start it up in “Self Testing Mode”.
Press the MENU button.
Select CLEANING.
Select INIT FILL.
The procedure may take up to 15 minutes to complete. Once complete, turn the printer off and back on normally.
5) It started filling and asked me to lift the levers up and down on each bay. Then I got a message to reset black ink. I fiddled and I shimmied to no avail, so I used the chip resetter on it and it worked from there with no shimmy needed.
6) Initial fill complete!!!