Black ink change on Epson 4800 printer flagged an error on the Magenta cartridge

After changing the MK to the PK ink, the printer flagged the Magenta cart as invalid. I reset the Magenta chip, reinstalled it with the same error; also it prompts the Cyan to be reinserted. The Cyan clears but the Magenta doesn’t. I thought the chip may be bad so I ordered another Magenta cart. I installed the new cart and I got the same error. I inspected the pins on the connector on that left bank. I unplugged the printer and discharged the caps. I left it unplugged for a couple of days. Afterward I powered it back up. There was no change in the printer except that one time it tried to initiate an ink charge but only got to 28% or so.


Do you mean to say that the print initiated on its own an ink charge?

It tried to initiate a charge after the black ink change, and requesting a reset on the Cyan cart.
The Magenta cart was flagged as ‘invalid’.

you may need to use a new chip on the Magenta cart in that case.

I bought and installed a new magenta cartridge with the chip with no change.

I purchased a new Magenta cart with the chip as the chips are not available for purchase. I installed the newly purchased cart with no change in status; ‘invalid cartridge’.

THis sounds more like a damaged pin reader at this point and the pin reader is not able to read the cartridge. You can use a flashlight and look into the ink bay where the cartridge’s chip would end up being read if inserted all the way in. Remove the adjacent cartridges and compare the pin reader in the Magenta position with the pin readers in the two adjacent channels. If it looks different - then it is damage and would need to be replaced. Let me know what you find out.

I got your phone message and there is only so much we can do to help support such an old printer. Your printer is not reading the chip on our cartridge. I belive that you have tried replacing the chip on your cartridge. Cartridges tend not to wear out, but pin readers to as well as the potential for being damaged. I think that before you try a new cart - you really need to inspect your pin reader and see if it is missing a pin or you see one or more dangling or damaged or just different looking than the ones adjacent to it.

I did checked the pins for damage before I submitted a problem to the forum. They looked ok compared to the other slots. I ran a mirror and a light to get a better look as the quarters are tight there. I will check it again as you advised. What would be the course of action to replace the connector if it was damaged or worn. I would suspect that if the pins looked straight, the problem would be that they are worn. Thanks in advance.

I’ll send you another 4800-M cartridge just in case. This printer is very old so Compass Micro would no longer sell EPSON parts for it. If you need a pin reader you will need most likely look for it on Alibaba.



Thank you for your help.