Batteries for the R3000 cartridges

printer

#1

Hi,

i have bought two different sets of replacement bateries for my cartridges, one was the Eunicell Alkaline that replaces the LR626, G4, SR626W batteries. None of them worked (bought 20). So i thought i better get a brand name, and go the Maxell SR626W batteries. Put one in, does not work. If i exchange a battery from a different cartridge to the one who’s battery is not working anymore, it works fine. And when i install the new batteries in the then battery free cartridge, the printert again does not recognize the battery. What the heck is going on? does not make sense to me. I is obviously not the chip that is faulty, cause it works fine if i use a battery from a different cartridge.


#2

Hi Matt~

I have only used the batteries that come with the chips, and the ones we sell, which have both worked well in my experience, though I know many customers have got their own batteries and had good results. From what you explain, I agree the chips seem to be fine, and your issue is battery related. We have information for replacing chip batteries here: http://www.inkjetmall.com/wordpress/product-use/r3000-cartridge-batteries/ and replacement batteries for sale here: http://shopping.netsuite.com/s.nl/c.362672/it.A/id.7586/.f?sc=18&category=84880

Sorry, I don’t know why the batteries you got aren’t working.
Best regards~ Dana


#3

I have followed the instructions to a T. It is an absolute mystery to me, since the batteries I bought are all the right kind/voltage and all … I have tried to purchase a couple of batteries from your site, but the shipping is prohibitive. It does not make sense to me to pay 27 bucks in shipping for a 3 dollar pair of batteries.


#4

As I said, I know several customers who have purchased their own batteries, and had good results, so I just don’t know why you’re not having good results with the batteries you purchased, but you have proven the chips are working well, and the issue is somehow battery related.