Another 3880 "Ink Cartridge Error" problem - but MAYBE with a twist.

Windows 10 Pro, ordinary computer.
Epson 3880 - it’s been using the InkJetMall refillable cartridges since the first factory one got empty. So a LOT of years. Always worked fine…

Periodically, especially if it’s been sitting for a month, I’ll pull the cartridges, give them a shake and put them back in. This time, ALL the cartridges were last filled in March 'cause there wasn’t much printing going on. I had it off for several weeks.

Turned it on, and got the "Ink Cartridge Error on the #6 Vivid Magenta slot. Pulled the cartridge, reseated, it, powered off, did the hokey pokey, all the normal stuff. Got the same error.

Pulled the cartridge out again, and in the small detent behind the circuit board was laying a small, gold pin, about 1/2 inch long…
It looks like a contact pin for the ink cartridge slot. Here’s a picture - the only thing I had handy to show size was a thumbtack.

I don’t have a factory cartridge sitting around, so I have nothing to put in there to see if it’ll work.

I presume I somehow managed to knock a contact pin out when I inserted or removed the cartridge. Can you even DO that?

I looked in the compartment where the cartridge goes, but I can’t tell anything. There are ends of gold pins sticking out way at the other end, but…

Has anybody had this happen? If so, PLEASE tell me there’s a reasonable way to FIX this, presuming the problem is a missing pin? I presume Epson doesn’t put in extras just in case?

This is what you need:,23232,35787,14494,15731


So this will fix it even IF there’s a pin missing from the socket where the cartridge goes?

I think Walker is interpreting your description as referring to the pins on the underside of the control chip.

If that is not the case, then the pin you found probably came from the connector at the upper right rear of the cartridge slot. There should be 7 pins – if you only see 6, that would be it. Here is a picture of a cartridge bay from a 3880 – the part is circled in red:

Here is a link to one source for the part: EPSON SureColor P800/3880/3890/ 4900/3850/3885 Contact Board

This supplier,, is in China. I have ordered parts direct from sources in China in the past with never a problem. Compass Micro does not have it. You may be able to find it from other suppliers in the US, or maybe not.

Good luck,

I just realized the picture I uploaded and thought I put in the original post didn’t show up. What I found on the cartridge may be just a PIECE of the contact pin? Or not a contact pin at all 'cause mine appears to have 7 pins and they aren’t the shape of the tiny metal piece I found… I think I’ll order the little board that goes on the cartridge and see if I get lucky.
I’m going to try to send the picture of the little piece of metal I found again…

-------- OK, that APPEARS to be a picture. But if it’s NOT something from the cartridge or contact, what IS it?

That definitely looks like a control chip pin. The smaller end is what sticks out and makes contact with the Epson chip beneath it. How it could get loose is another mystery. You might be able verify by removing the control chip from the problematic cartridge and seeing if a pin is missing. They only have 3 pins so it should be obvious.

Kind of glad to see this since I have no idea how to remove & replace the connector in the ink bay.


Are you saying this is something on the cartridge? Or it’s part of the printer, buried deep inside some inaccessible crevice? and if it IS on the cartridge is it UNDER the little circuit board? And if so, HOW do I get the little circuit board off? It’s been a LONG time since I put these together.

Click on Walker’s link above. It will take you right to the order page. Be sure to choose the one for the specific cart position. I think you said that it is VM, but be sure that is the right one.

A small flat-head screwdriver under the tab at the near end of the chip is all you need to remove it. Just slip the tip under and pry up gently. Flip it over and you will see the pins. Normally there are three. This one is probably missing one – the one that you found loose in the bay.

Here are a few pictures that may help:

The first two show removing the control chip. The third shows a closeup of the pins on the underside. And the last three show the critical step of sliding the tabs on the forward end into the slots on the cart and then pushing the back end down into position.







Hope this helps,

AHA! Finally, I see… Yes, when I pulled the control chip off there were only 2 pins. And yes, the 3rd pin was the one laying there. I pushed it BACK through the hole and the printer cleaned itself. I’ll order a replacement 'cause if this came out once, it’s gonna come out again… I printed a test page and it worked fine.