9900 Throwing "Error D17E" after replacing Ink Selector and Pump Cap Assembly

Hey Everyone,

I’m having an odd issue with my 9900 after having just replaced the dampers and pump cap assembly this past Friday. The installation of those two things took most of the afternoon (first timer), but went smoothly using the Service Manual as a guide. Following the instructions of the manual, I started the printer in serviceman mode after it was buttoned back up, and cleared the counters. Honestly, I was assuming that the menu setting would lead me to a menu to select a specific counter to clear, but instead it seems to have more or less done a factory reset on the printer - printer started up, ran an init fill, and printed a perfect nozzle check. I was bummed about the ink loss, but happy to see the printer back online.

Now whenever i run a print, the printer will run without any fuss but will kind of freeze as soon as the print finishes - the head scans back and forth like it’s checking for paper size/skew, and then immediately sends a warning to the panel “Code D17E Power Off and then On. If this Doesn’t Work, Note the Code and Call for Service”. The printer restarts just fine every time so far, but always throws the code after running a print after the head scans back and forth for about 30 seconds.

To my surprise, there is no mention of code D17E in the manual, and there is very little information to be found on the internet. The information I did find was all over the place - some say it’s a generic error that could be either hardware or software, some say it’s a network error (the printer is connected via ethernet), and some say it is a problem with the main board. I have uninstalled and reinstalled the print driver, added and removed the printer from the network, updated the firmware to the most recent version, and the error persists.

Has anybody come across this error? I haven’t had time to open the printer back up and check all of my connections, but I feel like I was pretty thorough, and would be surprised (albeit for no real reason) that the printer would boot up and run a print if a connection was bad or missing. The fact that the head passes back and forth over the edge of the paper before crashing out leads me to believe that it’s some kind of sensor issue, and looking at the wiring diagram I do see a few sensors coming off of Sub Board Assy B (which if I’m not mistaken, is the board that plugs into the pump cap assy). My biggest fear is that by clearing the counters in Serviceman Mode that I nuked something I shouldn’t have - I thought for sure it was going to bring me to another submenu, but as soon as I hit the right arrow it just launched into doing its thing and I didn’t dare stop it.

Any help or ideas would be immensely appreciated. I was very deliberate and careful with the job, and can’t think of any “oops” moments that could have shorted a board, but who knows. I did have the thought to try and run a print from another computer via usb, but haven’t had time yet and honestly It doesn’t seem like the connection is the issue. Any other ideas?

Thanks a million.
CJ Heyliger

This is most likely related to tension (error codes 17) and velocity (E). So most likely you have a tension error with your roll. Try a sheet paper as a debug. You may also simply have a dirty encoder strip or dirty paper feed encoder disk.

best,
Walker

Hi Walker,

Thank you (as always) for your reply. Your idea about the encoders makes sense to me - I’m about to dig into the printer and check them. Is there a suggested way of cleaning them? The error pops up with both sheet and roll paper, so I’m not sure if that steers us toward or away from any particular culprit.

I put this same post on the Epson Wide Format group and was told that the DXXX codes are debug codes that are usually tied to a failure on the main board. I found a new (used) main board for an ok price and it arrived yesterday. It seems like a drastic measure to me given that the printer still prints, but at the price it seemed like cheap insurance in case I can’t solve the problem through other means.

A friend of mine that works in IT suggested I try and reset the NVRAM as well. Any thoughts or pitfalls to look out for with that idea? The printer seemed to reset itself when I cleared the counters, so I’m wondering if the NVRAM wasn’t cleared out and that there is some conflict that is causing the printer to freak out.

I’ll keep this thread updated with what I find - there isn’t much information about these debug codes, but it seems that they do pop up from time to time. Hopefully this will help someone down the road.

cjh

Ok - so the plot is thickening, and I’m only getting more confused:

Before opening the printer up again I tried connecting my laptop to the printer via USB. I ran a print through photoshop (to isolate QTR from the problem) and to my surprise, the printer worked! I installed QTR on the laptop and was also able to make a print without any errors! Feels like I’m getting somewhere!

Next, I uninstalled and re-installed the epson print driver from my desktop computer, wheeled the printer over so that I could connect it via usb - tried to make a print (with my usual curve loaded that does not put GCO on the un-inked areas of the paper and error D17E came back after the print head scanned back and forth as though it was checking for skew/size. I power-cycled the printer.

I reconnected the laptop, ran a print with the NoGCO curve and the printer returned Error D17E - back to square one. I power-cycled the printer, ran a nozzle check to see if the printer would get beyond the size/skew check and the printer made a perfect nozzle check. I ran a print via photoshop and it worked without any fuss. I ran a print through QTR using the standard warm curve that I used on my first successful QTR print and it worked! I loaded my NoGCO curve and the print head scanned back and forth, and returned Error D17E.

I have repeated this three times now and have gotten identical results. Is there any reason why the NoGCO curve would cause the printer to return that error?