9890 VM channel not drawing ink

9890
7900
9900
7890

#1

Hello,

Hoping someone can help, I’ve used Cone Inks in my 9890 for the last year. The VM channel is completely missing from nozzle checks, I can clearly see that there is no ink the line at all, I did an initial fill and it made no changes, but, the ink level in the cart didn’t drop at all. So thinking (optimistically, or naively) that I had a bad cart, I ordered a new one, and attempted another initial fill, still no change, still no ink in the line at all, and the ink level in the new cartridge didn’t drop at all.

Any advice would be greatly appreciated.


#2

Entire channels dropping is a depressingly normal thing with these printers (x890s and x900s).

It’s the print-head. There is a chance that it could be cleared with some aggressive maintenance cleaning procedures . . . .

best,
Walker


#3

Its difinitively the printhead even though there’s no ink in the line and the cartridge never empties? I guess I just don’t understand that.


#4

Really? No ink in the line? Confirmed? Sorry, I miss-read that.

If there is air than it is air-locked somewhere at the ink-bay at the cartridge! This could be a cartridge that is unable to pressurize or a that has become blocked at the seal . . .

Private message me with your order details and we’ll take care of it.

best,
Walker